Grandstream 4104 possesed by the devil...

Discussion in '3CX Phone System - General' started by iamgreen, Feb 22, 2008.

Thread Status:
Not open for further replies.
  1. iamgreen

    Joined:
    Sep 25, 2007
    Messages:
    52
    Likes Received:
    0
    Hello,

    I have my 3CX server nearly ready for production. We are using it internally at our office before we start our push to our SMB clients. Everything has gone well and we love it with one exception. The Grandstream 4104 ATA that we chose is not working and I am not sure where to turn. Here is the breakdown.

    Sometimes I can place calls from my phone to the PSTN without any problems. I can see the ATA grab line 1 of 2 and dial out just fine. Other times I dial the same number, using the same phone and I will see line 1 of 2 on the ATA flash for a moment. Meantime my handset just acts like I am on a call. No timeout or anything.

    A close look a the logs...

    When place a successfull call it looks like this...

    18:54:51.234 Call::Terminate [CM503008]: Call(13): Call is terminated
    18:54:10.078 CallCtrl::eek:nLegConnected [CM503007]: Call(13): Device joined: sip:10000@192.168.111.12:5060
    18:54:10.078 CallCtrl::eek:nLegConnected [CM503007]: Call(13): Device joined: sip:801@192.168.111.115:5060;transport=udp
    18:54:10.062 Line::printEndpointInfo [CM505002]: Gateway:[VZ] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Grandstream GXW4104 (HW 0001, Ch:8) 1.0.1.2] Transport: [sip:192.168.111.11:5060]
    18:54:07.203 CallCtrl::eek:nSelectRouteReq [CM503004]: Call(13): Calling: PSTNline:10000@[Dev:sip:10000@192.168.111.12:5060, Dev:sip:10001@192.168.111.12:5060]
    18:54:07.093 CallCtrl::eek:nIncomingCall [CM503001]: Call(13): Incoming call from Ext.801 to [sip:92065551212@192.168.111.11]

    When a call fails it looks like this..

    19:23:11.562 Call::Terminate [CM503008]: Call(14): Call is terminated
    **during this time I am listening to dead air on my handset. Then when I hang up
    19:21:18.375 CallCtrl::eek:nSelectRouteReq [CM503004]: Call(14): Calling: PSTNline:10000@[Dev:sip:10000@192.168.111.12:5060, Dev:sip:10001@192.168.111.12:5060]
    19:21:18.250 CallCtrl::eek:nIncomingCall [CM503001]: Call(14): Incoming call from Ext.801 to [sip:92065551212@192.168.111.11]

    Then to add insult to inury the ATA works great for inbound calls everytime. Has anyone seen this before?
     
  2. Anonymous

    Anonymous Guest

    I had nightmares with my GS 4104 until I tweaked onto the right setting for current disconnect threshold. Under FXO lines try bumping up the threshold from the default (100) to 800 (max). Then see how it does. If that helps you can try dropping the threshold until you find something that seems stable. I had to play with mine a lot to get it right. On a a Verizon POTS line I had to leave it at about 600-700 to work. Then I had a different Telco where it works well at the default setting of 100. Apparently it has something to do with equipment in use at the local telco CO (I suppose).

    Also, be sure you have the current firmware. That also helped a lot. In the Advanced settings on the GS you can set it to upgrade via TFTP and set the server path to 168.75.215.189. Then reboot the GS and it should upgrade if needed upon startup.

    This might not help much as I am no expert on the GS, that's just what I hit on to make it work reasoably well after weeks of frustration. In my experience the Grandstream is still a bit squirrely with strange noises on occasion (like a short squeal) but I guess that is why they're cheap.
     
  3. bluefox8080

    bluefox8080 New Member

    Joined:
    Oct 28, 2007
    Messages:
    181
    Likes Received:
    0
    Thank you valley for the TFTP Update IP address. It works great.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. iamgreen

    Joined:
    Sep 25, 2007
    Messages:
    52
    Likes Received:
    0
    OK, so level with me....is this ATA a steaming pile of doo doo? I have it all setup now, but I am having LOTS of problems.

    1: 1 out of 20 calls will hang up at 5 minutes into the conversation

    2: When another person places a call outbound they will cause other calls to disconnect.

    Is there a better ATA? At this point I am willing to just buy a new one to avoid this battle.
     
  5. AldoLinares

    AldoLinares New Member

    Joined:
    Nov 12, 2007
    Messages:
    135
    Likes Received:
    0
    I am waiting for a Audiocodes mp-114 i just want to replace my GXW4104 it simple dont work.

    1.- Lines disconnect random
    2.- Strange noises
    3.- Delay
    4.- Some clipping sound
    5.- Sometimes when you speak at the same time it just shorts the conversation.

    I really dont recommend this gateway even i try to contact grandstream and they just reponded like 3 days after every mail i send them, and i typed like all the info different test i did there answeres after 3 days. Update your firmware... man i just send it on the email my firmware it was up to date.

    So i dont know if it was just me.
     
  6. iamgreen

    Joined:
    Sep 25, 2007
    Messages:
    52
    Likes Received:
    0
    Good to hear I am not the fault in this device. I will start shopping for a new one. 3CX seems pretty hep to the patton series of ATA's anyone have anything good to say.
     
Thread Status:
Not open for further replies.