Grandstream GXP-2000 doesn't register itself again

Discussion in '3CX Phone System - General' started by bdevre, Jun 21, 2007.

  1. bdevre

    Joined:
    Jun 21, 2007
    Messages:
    12
    Likes Received:
    0
    I am using a GXP-2000 in combination with 3CX VPBX.
    After the Register Expiration time (for example 10 minutes) is passed, the 3CX log tells that the extention of my device has expired and it is no longer registered.

    I can only put a value with a max. of 45 days as the 'Register expiration'-parameter. I want the extention never to expire. How can I get this to work?

    Thanx,

    Bart
     
  2. cjammer

    cjammer New Member

    Joined:
    Dec 21, 2006
    Messages:
    109
    Likes Received:
    0
    I have the same problem. with mine. I have a BT-102 and it will re-register.

    If you find out anything drop me a line. I would like to fix this issue also.

    Cjammer
     
  3. bdevre

    Joined:
    Jun 21, 2007
    Messages:
    12
    Likes Received:
    0
    In my case it doesn't reregister. If it would my problem was solved.
     
  4. cjammer

    cjammer New Member

    Joined:
    Dec 21, 2006
    Messages:
    109
    Likes Received:
    0
    When my 2000 boots it will register then. After the set time it unregisters and will not re-register till I reboot the phone. If I reboot the server, it will not re-register either.

    I have looked for a firewall setting to be the problem, but have yet to find a cure for it.

    Cjammer
     
  5. bdevre

    Joined:
    Jun 21, 2007
    Messages:
    12
    Likes Received:
    0
    SIP server and GXP2000 on same LAN without any firewall in between and i've got the exactly the same problem. So let's wait for a solving answer.
     
  6. John2007

    Joined:
    Apr 14, 2007
    Messages:
    16
    Likes Received:
    0
    It's GXP 2000 problem. I searched on net and found only upgrade firmware can solve it. However, the beta version firmware which sloved the problem was removed from Grandstream web site.
     
  7. cjammer

    cjammer New Member

    Joined:
    Dec 21, 2006
    Messages:
    109
    Likes Received:
    0
    Thats good to hear... Sort of.

    Anyone found a good fix for it yet?
     
  8. Costas3CX

    Costas3CX New Member

    Joined:
    Jan 23, 2007
    Messages:
    217
    Likes Received:
    0
    I have the GXP2000 with this version firmware...

    Program-- 1.1.1.14 Bootloader-- 1.1.1.5

    no problems whatsoever. I have it set to 10 minutes...It doesn't show as unregistered, in fact every 10 minutes it re-registers if you go through the server status...You can find it here...

    http://www.grandstream.com/firmware.html
     
  9. bdevre

    Joined:
    Jun 21, 2007
    Messages:
    12
    Likes Received:
    0
    How odd.

    I've got following versions :
    Program 1.1.2.23 Bootloader 1.1.1.5

    This is odd because the official approved firmware =
    Program 1.1.1.14 Bootloader 1.1.1.5

    I have downloaded it and will give it a try.
    I'll let you know.

    Bart
     
  10. bdevre

    Joined:
    Jun 21, 2007
    Messages:
    12
    Likes Received:
    0
    Hello,

    good news.

    After a downgrade of the firmware version the GXP2000 seems to reregister without any problems.

    Thanx for the ideas.
    I hope this solution works for you all.

    Bart
     
  11. 3CXsupport

    3CXsupport New Member
    3CX Staff

    Joined:
    Aug 21, 2006
    Messages:
    193
    Likes Received:
    0
    Thanks for pointing it out.
     
  12. cjammer

    cjammer New Member

    Joined:
    Dec 21, 2006
    Messages:
    109
    Likes Received:
    0
    I have successfully upgraded (downgraded) one of mine and it seems to be working now too.

    Cjammer
     
  13. bdevre

    Joined:
    Jun 21, 2007
    Messages:
    12
    Likes Received:
    0
    I just received a new beta-firmware from grandstream. (version 1.1.2.27)
    I'll install this one to see if it works fine.

    Bart
     

Share This Page