Grandstream GXW-4104 always binds to media server

Discussion in '3CX Phone System - General' started by SteveC, Oct 19, 2007.

  1. SteveC

    Joined:
    Oct 14, 2007
    Messages:
    3
    Likes Received:
    0
    Hi

    I'm trying to stop my GXW-4104 from binding to the media server in 3CX in an attempt to reduce the audio delay.

    I have turned off the "PBX delivers audio" flag on the settings page for the gateway in 3CX, but 3CX is telling the extension to talk direct to the gateway, which I can see it does from the pcap on the handset (snom 300), and then telling the GXW to talk to the media server. The pcap on the snom shows no RTP coming from the GXW or anywhere else.

    The consequence of this is that there is no audio. This only happens on calls from external landlines via the gxw. Calls from extensions going out have the media server invoked for both the extension and the gateway, despite what I have specified in the setup.

    There are no STUN settings on either the handset or gateway, although there is on the 3CX. The handset is not bound to the media server or marked as external.

    I have the server logs to show what happens:

    example 1:
    external landline to incoming landline to internal extension
    no audio
    pbx delivers audio = unchecked

    18:55:01.296 CallConf::eek:nIncoming [CM103002] Call(1): Incoming call from 10001 (Ln:10001@GXW-4104) to sip:10001@192.168.222.245
    18:55:01.531 CallConf::eek:nProvisional [CM103003] Call(1): Ext.101 is ringing
    18:55:07.328 CallLegImpl::eek:nConnected [CM103001] Call(1): Created audio channel for Ln:10001@GXW-4104 (192.168.222.239:5032) with Media Server (192.168.222.245:7352)
    18:55:07.328 StratInOut::eek:nConnected [CM104005] Call(1): Setup completed for call from Ln:10001@GXW-4104 to Ext.101
    18:55:07.343 CallLegImpl::eek:nConnected [CM103001] Call(1): Created audio channel for Ext.101 (192.168.222.10:50528) with third party (192.168.222.239:5032)

    ------------

    example 2:
    int extension via external landline to external landline
    audio OK
    pbx delivers audio = unchecked

    18:57:18.468 CallConf::eek:nIncoming [CM103002] Call(2): Incoming call from 101 (Ext.101) to sip:80123456789@192.168.222.245
    18:57:20.625 CallConf::eek:nProvisional [CM103003] Call(2): Ln:10001@GXW-4104 is ringing
    18:57:20.625 CallLegImpl::eek:nConnected [CM103001] Call(2): Created audio channel for Ext.101 (192.168.222.10:59166) with Media Server (192.168.222.245:7356)
    18:57:20.625 StratInOut::eek:nConnected [CM104005] Call(2): Setup completed for call from Ext.101 to Ln:10001@GXW-4104
    18:57:20.625 CallLegImpl::eek:nConnected [CM103001] Call(2): Created audio channel for Ln:10001@GXW-4104 (192.168.222.239:5004) with Media Server (192.168.222.245:7358)

    ------------

    example 3:
    external landline to incoming landline to internal extension
    audio OK
    pbx delivers audio = checked

    19:06:50.109 CallConf::eek:nProvisional [CM103003] Call(3): Ext.101 is ringing
    19:06:51.734 CallLegImpl::eek:nConnected [CM103001] Call(3): Created audio channel for Ln:10001@GXW-4104 (192.168.222.239:5008) with Media Server (192.168.222.245:7360)
    19:06:51.734 StratInOut::eek:nConnected [CM104005] Call(3): Setup completed for call from Ln:10001@GXW-4104 to Ext.101
    19:06:51.734 CallLegImpl::eek:nConnected [CM103001] Call(3): Created audio channel for Ext.101 (192.168.222.10:61014) with Media Server (192.168.222.245:7362)


    Why is 3CX ignoring the setting for PBX to *not* deliver audio on the gateway?

    I would greatly appreciate any help with this

    Steve
     

Share This Page