Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Solved Grandstream GXW-4104 Audio issue

Discussion in '3CX Phone System - General' started by grantg, Dec 8, 2018 at 2:06 AM.

Thread Status:
Not open for further replies.
  1. grantg

    Joined:
    Dec 2, 2018
    Messages:
    5
    Likes Received:
    1
    Hi,

    I have a Grandstream GXW-4104 connected to 4 POTS lines.

    I created a gateway per the 3CX article "Configuring Grandstream FXO VoIP Gateway" (https://www.3cx.com/voip-gateways/grandstream-fxo/) My firmware is 1.4.1.5.

    I ran all the AC Impedance Tests in the GXW-4104. The documentation from Grandstream implied any necessary changes would be made automatically by running the Tests.

    I created Outbound Rules.

    I made a call and it connected. The person I called had a hard time hearing me. I could hear them just fine. I did this several times to test. All tests had the same results. I could hear them, but they could not hear me very well.

    I used my cell phone to make an inbound call to the main number that connected to port 1 of the Gateway. The call was sent to the Auto Attendant that I setup. The recording was very choppy. It seemed like little parts of the Audio stream was dropped along the way. Maybe every other packet was dropped (this is just a guess and I'm really just trying to describe what the audio sounded like.)

    I connect a standard phone to the POTS lines and made outbound calls with good audio quality.

    I am using 3CX 15.5 Running on Windows 2012 R2 in a VM on a very beefy Dual Xeon server. It is the only VM running on the server.

    Does anyone have an idea of what may be going wrong or what settings I need to make to the GXW-4104 to get the outbound audio quality acceptable?
     
  2. eddv123

    eddv123 Well-Known Member

    Joined:
    Aug 15, 2017
    Messages:
    1,412
    Likes Received:
    186
    It sounds to me like a line quality issue on the Telco side, I would check with them as well as how far away from the central office you are.

    If you want to do something on your side you could try a codec change, analogue voice ports take incoming audio and pass it through a PCM codec device. I believe you are probably going to be using Ulaw codec as standard.
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,095
    Likes Received:
    327
    Did you try inbound calls from something other than your Mobile? A land-line? Are there multiple PSTN lines on the gateway? If so, and the issue happen on different originating sources, then check to see if it is happening on certain PSTN lines only. Swap the Phone jacks around and see if the problem "moves" as well. You can also see if the 3CX Activity logs show any indication of Codec transcoding. As mentioned above, the codec, suggested by the gateway, on incoming calls, may currently not be the best choice.
     
    #3 leejor, Dec 8, 2018 at 6:22 PM
    Last edited: Dec 8, 2018 at 11:00 PM
  4. cobaltit

    cobaltit Well-Known Member

    Joined:
    Mar 22, 2012
    Messages:
    1,590
    Likes Received:
    239
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    grantg likes this.
  5. grantg

    Joined:
    Dec 2, 2018
    Messages:
    5
    Likes Received:
    1
    It was the Broadcom NIC.

    I issued the powershell command listed in the Microsoft article and the problem went away.

    Boy, i tried every codex listed in the Grandstream Gateway with no help.

    I did find one setting that helped some. It was in the Grandstream web interface. Settings...Call Settings...Voice Frames per TX: It was defaulted to 2 and it allowed me to set it up to 10. A setting of 10 made things better, but still not perfect.

    The Broadcom VMQ bug was the problem.

    Thank you very much!
     
  6. cobaltit

    cobaltit Well-Known Member

    Joined:
    Mar 22, 2012
    Messages:
    1,590
    Likes Received:
    239
    I figured as much. Just don't ask me how I know! :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. eddv123

    eddv123 Well-Known Member

    Joined:
    Aug 15, 2017
    Messages:
    1,412
    Likes Received:
    186
    Thanks for being considerate enough to post what you tried and what settings helped the issue, as this will most likely be useful for other forum members in the future. Since they have become supported by 3CX Grandstream are becoming a popular gateway for 3CX Partners.
     
  8. cobaltit

    cobaltit Well-Known Member

    Joined:
    Mar 22, 2012
    Messages:
    1,590
    Likes Received:
    239
    And just to clarify this had nothing to do with the Grandstream ATA. The Broadcom VMQ issue will cause audio issues period, with or without an ATA.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.