Grandstream GXW pstn lines don't auth.

Discussion in '3CX Phone System - General' started by nolan, Apr 16, 2007.

  1. nolan

    Joined:
    Apr 16, 2007
    Messages:
    3
    Likes Received:
    0
    I have a Grandstream GXW41 with 4 analog pstn lines connected.
    The problem is that only the first line will connect with the connected SIP Grandstream phones. Incoming pstn line 2, 3 and 4 gives authentication problems.
    Think its only a simple problem but I cann't find it....
    All ID and psw are ok.

    onAuthFailure Registration request from sip:unknown@192.168.1.58 failed. Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    19:02:59.215 AuthMgr::requestCredential Message SipReq: INVITE 1000@192.168.1.58 tid=41b65eb7c9f64bc6 cseq=INVITE contact=1001@192.168.1.200:5062 / 29753 from(wire) failed authentication!
    19:02:59.215 AuthMgr::requestCredential Authentication ID for Ln:1000@gateway doesn't match provided: 1001 vs 1000
    19:02:49.215 AuthMgr::eek:nAuthFailure Registration request from sip:00627031807@192.168.1.58 failed. Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    19:02:49.215 AuthMgr::requestCredential Message SipReq: INVITE 1000@192.168.1.58 tid=7393d05756041f47 cseq=INVITE contact=1001@192.168.1.200:5062 / 30135 from(wire) failed authentication!
    19:02:49.215 AuthMgr::requestCredential Authentication ID for Ln:1000@gateway doesn't match provided: 1001 vs 1000
    Anyone an idea?
     
  2. netmatika

    Joined:
    Feb 16, 2007
    Messages:
    17
    Likes Received:
    0
    Hi nolan,
    i have same hardware...
    first you setup the 4 incoming PSTN lines on 3CX...
    for the initial test i've done:
    add PSTN lines from 10000 to 10003 and assing the same password at corrispondent ID...ex...ID 10000 pass 10000...etc...
    on GWX setup assign 1 channel to one line...ex id 10000 channel 1...
    does it work?

    Netmatika
     
  3. nolan

    Joined:
    Apr 16, 2007
    Messages:
    3
    Likes Received:
    0
    Yep the first line works fine. In- and outgoing.
    Then i try 2 lines. Did the same you did. But incoming calls on the second line gives the problem. 1e line works fine.
    -Authentication ID for Ln:10000@gate doesn't match provided: 10001 vs 10000
    -Message SipReq: INVITE 10000@192.168.1.58 tid=1964d1a4d046ba62 cseq=INVITE contact=10001@192.168.1.200:5062 / 18671 from(wire) failed authentication!
    -Registration request from sip:00611111111@192.168.1.58 failed. Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings

    Perhaps the advanced setting for the gateway.

    But if you have everything working. Perhaps i can use your settings?
    My private email is nolandnol@gmail.com

    Thanks
    Nol Kloosterman
    Holland
     
  4. nolan

    Joined:
    Apr 16, 2007
    Messages:
    3
    Likes Received:
    0
    Found it.
    Very simple...;-(
    Grandstream config FXO line.
    6. Offhook Auto Dial(VoIP): option....
    You have to put in every channel separately.
    My config was that all the lines uses the first channel.

    Perhaps also possible by changing the 3cx config. But this works also.

    Thanks
    Nol
     
  5. netmatika

    Joined:
    Feb 16, 2007
    Messages:
    17
    Likes Received:
    0
    3CX setting

    Hi Nolan,
    i'm glad that your 3CX now functions...
    if you have anothers problems, we can share our experience and settings.

    Best regards from Italy

    Netmatika
     

Share This Page