Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Solved Grandstream GXW4104 no incoming call

Discussion in '3CX Phone System - General' started by armandoangeles, Jan 17, 2017.

Thread Status:
Not open for further replies.
  1. armandoangeles

    Joined:
    Jul 28, 2015
    Messages:
    4
    Likes Received:
    1
    Is there someone encounter issue with GXW4104 regarding with incoming call?
    I am currently using the latest version of 3CX Phone 15, All the outgoing call run without any issue while the incoming call is the one has problem.

    If I dial the number attached on the gateway I can hear 2 ring and then busy tone.

    I tried to follow this link http://www.grandstream.com/sites/default/files/Resources/gxw410x_interop_3cx.pdf
    but did not work.
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,811
    Likes Received:
    564
    Hello @armandoangeles

    Have you created an inbound rule for this gateway? Does the call reach the PBX? Set the logging to verbose by navigating to Dashboard/ Activity Log/ settings and set it to verbose. Restart all services.
    then try calling in and see if you are getting an error in the logs.
     
  3. armandoangeles

    Joined:
    Jul 28, 2015
    Messages:
    4
    Likes Received:
    1
    Hi @YiannisH_3CX

    Yes I created inbound rule for the Grandstream Gateway

    upload_2017-1-18_9-54-13.png

    It seem that the call from the gateway did not reach on the 3CX Phone System, I can't find any activity log from the gateway to 3CX Phone system when I call the number attached on the gateway. (logging set to verbose already)
     
  4. armandoangeles

    Joined:
    Jul 28, 2015
    Messages:
    4
    Likes Received:
    1
    Hi @YiannisH_3CX

    I already resolved the issue, the problem relay on the Gateway GXW4104 configuration.

    - Navigate to Settings > Channel Settings
    - Under Calling to VoIP,
    + User ID = ch1-4:1001; <-- 1001 will be your extension destination on the 3CX Phone System
    + SIP Server = ch1-4:p1;
    + SIP Destination Port = ch1-4:5060;
     
    Andyshawn likes this.
  5. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,811
    Likes Received:
    564
    Glad to hear the issue is resolved and thank you for sharing your solution
     
  6. eav

    eav

    Joined:
    Oct 31, 2016
    Messages:
    1
    Likes Received:
    0
    Hi,

    I am facing an issue like that, but with outbound calls.

    Do you guys know what could be causing this?

    Thanks in advance.
     
Thread Status:
Not open for further replies.