Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Grandstream outbound call problem

Discussion in '3CX Phone System - General' started by iperez_genius, Jul 21, 2008.

Thread Status:
Not open for further replies.
  1. iperez_genius

    Joined:
    Jul 1, 2008
    Messages:
    56
    Likes Received:
    0
    I jsut go a grandstream 4104
    my system is setup and all pstn lines are registering...

    I have only 1 fxo port being used with 1 pstn line connected...

    the pstn lines created are
    10000
    10001
    10002
    10003

    I can receive incoming calls and everything looks fine from that side but i can't make outbound calls.

    I have set the outbound proxy on the grandstream to the same value as the 3cx server address...

    I have setup an outbound rules for the grandstream line 1...

    that says
    numbers beginning with
    990
    for extensions 1207
    for numbers with lenght 11

    it is setup this way because if i want to make a local call the number is

    93440154 - 8 digits
    +990 == 11 digits

    is there anything i am missing in my setup?

    Ilan
     
  2. Anonymous

    Anonymous Guest

    Do you then need to strip the 990?
     
  3. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    1
    Hi Ilan,
    If you unable to issue calls which the numbers beginning with 990. You will hit the default function code with GXW410x's "Prefix to Specify Port". That's mean issue this call via FXO port 0. However, the FXO port numbers should be 1 to x. Please try to change its default value from "99" to "09" at :
    Channels->Port Scheduling Schema (Voip->PSTN)->2. Prefix to Specify Port(1 stage dialing method)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. iperez_genius

    Joined:
    Jul 1, 2008
    Messages:
    56
    Likes Received:
    0
    it looks like i am getting closer but still it wont call out...

    I have edited the outbound rule so that the prefix is now

    091

    following the syntax shown in the grandstream setup screens

    (Syntax: prefix# + ch# + dialing# will request the ch# per call)

    the prefix is 09 +
    the channel is 1 +
    the number is 8 digits
    93472255

    therefore

    09193472255

    The phone in the office doesn't ring.

    In the rule i am removing the first 3 digits

    here is the server status for making the call and then terminating it.

    10:53:26.640 Call::Terminate [CM503008]: Call(15): Call is terminated
    10:53:26.562 Call::RouteFailed [CM503015]: Call(15): Attempt to reach [sip:09183472244@192.168.43.222:5060] failed. Reason: Server Failure
    10:53:26.562 CallLeg::eek:nFailure [CM503003]: Call(15): Call to sip:09183472244@192.168.43.3:5060 has failed; Cause: 503 Service Unavailable; from IP:192.168.43.3:5060
    10:53:26.453 CallLeg::eek:nFailure [CM503003]: Call(15): Call to sip:09183472244@192.168.43.3:5060 has failed; Cause: 503 Service Unavailable; from IP:192.168.43.3:5060
    10:53:26.343 CallLeg::eek:nFailure [CM503003]: Call(15): Call to sip:09183472244@192.168.43.3:5060 has failed; Cause: 503 Service Unavailable; from IP:192.168.43.3:5060
    10:50:25.968 CallCtrl::eek:nSelectRouteReq [CM503004]: Call(15): Calling: PSTNline:09183472244@(Ln.10001@DDpstnLine)@[Dev:sip:10001@192.168.43.3:5062, Dev:sip:10002@192.168.43.3:5064, Dev:sip:10003@192.168.43.3:5066, Dev:sip:10000@192.168.43.3:5060] 10:50:25.953 CallCtrl::eek:nSelectRouteReq [CM503010]: Making route(s) to [sip:09183472244@192.168.43.222:5060]


    Last thing i may nee to mention is that i am using the 3CX softphone.

    Any help would be greatly appreciated

    Ilan
     
  5. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    1
    Please let us know the
    1.) exact number which in need to send to PSTN

    2.) 3CX outbound rule setting
    3.) GXW4104 "Prefix to Specify Port" setting
    4.) dial string from 3CX client
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.