Granstream BT-102 as External only outgoing work

Discussion in '3CX Phone System - General' started by AldoLinares, Dec 2, 2007.

  1. AldoLinares

    AldoLinares New Member

    Joined:
    Nov 12, 2007
    Messages:
    135
    Likes Received:
    0
    I have setup a 3CX Box and it's perfectly working since install, i have a hardphones and softphones on it.

    The setup is is as follows:

    3CX:
    Port Mapping:Every need it port mapped
    pstn line: linksys 3102
    Ext: 301 as external & bind to media server
    STUN: stun.3cx.com

    BT-102: On different network behind router
    DHCP: OK
    STUN: stun.3cx.com
    Nat Traversal: YES = detected NAT type is full cone
    NAT: FULL CONE
    STATUS: registerd = YES
    Local SIP PORT: 5060
    Local RTP Port: 5004

    Can do:
    Can make call from the external BT-102 to PSTN Numbers via 3CX and internet every call its fine and works perfectly:

    Can't do:
    If i call pstn >> 3CX PSTN(linksys 3102) and dial extension 301(bt-102 external) it rings and i can see even the number but when i hook off there is no sound, and on the other end it's like the transfer music.

    Estrange:
    It works perfect extension 301 on the softphone x-lite as external both ends.

    Any help

    I trying everything related to nat and firewall behind the hardphone even map the ports and nothing same result:

    Here es the last log lines:

    02:24:16.453 StratInOut::eek:nHangUp [CM104007] Call(3): Call from Ln:10001@Telnor (7008110) to 301 has been terminated by Ln:10001@Telnor (7008110); cause: BYE; from IP:172.16.4.200
    02:23:52.359 MediaServerReporting::DTMFhandler [MS211000] Call(3) Ln:10001@Telnor (7008110): DTMF (RTP) from 172.16.4.200:16430 arrived. in-band DTMF tone detection is turned off.
    02:23:47.812 CallLegImpl::eek:nConnected [CM103001] Call(3): Created audio channel for Ln:10001@Telnor (7008110) (172.16.4.200:16430) with Media Server (172.16.4.90:7004)
    02:23:47.781 CallConf::eek:nIncoming [CM103002] Call(3): Incoming call from 6646318163 (Ln:10001@Telnor (7008110)) to sip:%3C10001@172.16.4.90
     
  2. AldoLinares

    AldoLinares New Member

    Joined:
    Nov 12, 2007
    Messages:
    135
    Likes Received:
    0
    Should i change to other phones?
     
  3. ackrts

    Joined:
    Feb 5, 2008
    Messages:
    7
    Likes Received:
    0
    Hello,
    Was this issue ever resolved? I am having the exact same issue with a BT 100. Is it the phone, or a setting that can be changed? Anyone gotten it to work?!

    Thanks!
     

Share This Page