Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

groups showing wrong caller i.d.

Discussion in '3CX Phone System - General' started by steve997, Jan 30, 2015.

Thread Status:
Not open for further replies.
  1. steve997

    Joined:
    Jan 30, 2015
    Messages:
    4
    Likes Received:
    0
    Hi,
    I'm using 3CX version 12.5

    I have made a GROUP comprising 5 phones and called it 'main'. When an incoming external call is coming in, all the phones show 'main' as the caller i.d. however I still want the original call number id to be displayed.

    FYI, if the call is answered on one phone then transferred to another, it will then show the original caller i.d.

    I used to have this working fine in version 11. Not sure what we did originally or if anything changed between versions... any help greatly appreciated.

    Cheers Steve
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,101
    Likes Received:
    329
    You might try removing, or changing, the option of having the Ring Group name added to the caller ID. See what shows up when you do that. then try adding it back again. The RG name may be "pushing aside" the actual caller ID in the sets display
     
  3. steve997

    Joined:
    Jan 30, 2015
    Messages:
    4
    Likes Received:
    0
    Hi Lee,
    I'm not that great at 3CX yet.. where do I look for that option?
    Cheers,
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,101
    Likes Received:
    329
    You should find the option under...Settings/General/Global Options

    What type of sets are you using? I came across this...

    http://www.3cx.com/forums/caller-id-to-display-vs-ringing-group-name-30476.html
     
  5. steve997

    Joined:
    Jan 30, 2015
    Messages:
    4
    Likes Received:
    0
    yep, I'm on SNOM 870 as well. I'll check those settings on the sets tomorrow when I pop into the office.
     
  6. steve997

    Joined:
    Jan 30, 2015
    Messages:
    4
    Likes Received:
    0
    OK, had success thanks to your posts.

    There’s two ways: You can change the Snom 870 preference setting for Number Display Setting from NAME to NUMBER.
    The problem I think with that is it will always show only the incoming number, even if the incoming call is an IP phone with a name ID attached.

    The better option is in 3CX - SETTINGS / GENERAL / GLOBAL OPTIONS and untick the Inbound Name to Caller ID option.

    Many thanks for your insight..
     
Thread Status:
Not open for further replies.