GS and Snom Phones Echo and Crackle

Discussion in '3CX Phone System - General' started by cknott2243, Mar 2, 2012.

Thread Status:
Not open for further replies.
  1. cknott2243

    Joined:
    Jul 6, 2010
    Messages:
    49
    Likes Received:
    0
    I recently moved from an Asterisk box to 3cx and now all of a sudden all of my phones crackle and Echo at certain points throughout a call. It seems to be the first few words of any sentence this happens to.

    I have 3cx v10 SP5 and it is connected to a Grandstream 4108 8 FXO gateway. I am not sure the problem is in 3CX or the GS FXO GW but hoping someone might have an idea. I am new to the VoIP space so might be missing some easy signs to the problem and how to fix it.

    Any ideas?

    Thanks.
     
  2. cknott2243

    Joined:
    Jul 6, 2010
    Messages:
    49
    Likes Received:
    0
    I fixed it. At one point I increased the gain from 1 to 10 and then this started.

    I originally increased this because the VM quality was extremely low and could barely be heard. This is a separate problem and will open a thread on it.

    Thanks.
     
  3. millsey

    millsey New Member

    Joined:
    Dec 21, 2011
    Messages:
    190
    Likes Received:
    0
    Not sure if the Grandstream gateway has the same behaviour as the Grandstream phones but for us setting the Jitter Buffer within the Grandstream to 100ms instead of 300ms (both adaptive mode) fixed a lot of outbound audio problems - where parts of words could not be heard.

    Millsey
     
  4. taborrally

    Joined:
    Mar 30, 2012
    Messages:
    1
    Likes Received:
    0
    Sorry for my ignorance, but did you change the TX gain or the RX gain? Perhaps you could share what your settings are on the 4108's config page. I am having similar issues that I have been tracking down!
     
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,868
    Likes Received:
    304
    When dealing with echo problems and an analogue gateway, put all gain settings at the factory default and go (slowly) from there. If it is the far end hearing echo, then it is probably too high of a level coming in towards you. If you hear it, then you are probably sending out too high of a level. The factory setting should work in most cases (be sure all settings correspond to the country you are using the gateway in) and should only require a slight tweak.

    Any drastic level issues should be confirmed with an analogue set directly on the phone line, and if needed, reported to your service provider.
     
Thread Status:
Not open for further replies.