GSM gateway settings for uplink

Discussion in '3CX Phone System - General' started by Pete-TPP, Jun 23, 2009.

Thread Status:
Not open for further replies.
  1. Pete-TPP

    Joined:
    Dec 31, 2006
    Messages:
    24
    Likes Received:
    0
    I have the Gempro GSM gateway attached to the phonesystem. Since the update to 3cx 7.1 the uplink to: 79@10008 (receptionist@linenumber) does not work anymore. Anyone any suggestions?
     
  2. bluetel2

    bluetel2 Member

    Joined:
    Oct 16, 2008
    Messages:
    377
    Likes Received:
    6
    hello,

    ok ut can you send the log file and little description of your network, do you have converter ? etc... because like this ... :roll: it's complicated.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Pete-TPP

    Joined:
    Dec 31, 2006
    Messages:
    24
    Likes Received:
    0
    Sorry for late response but I did not recieve an ermail with your update. Settings are:

    Gempro with Sim (status registered) is connected via lan to 3cx. Outbound calls are no problem. Inbound calls seem to have wrong uplink settings wich used to work with old 3cx. I tried as uplinkname:
    receptionist: 91
    receptionist@3cxserver: 91@192.168.4.4 (this one used to work fine, but now phone rings once or twice and then disconnected)
    pstnline@3cxserver: 10008@192.168.4.4
    Nothing at all
    *
    And other settings

    The device does recieve tha calls in that log but does not send them trough

    Systemlog(tell me if you need more)
    10:13:16.889 [CM102001]: Authentication failed for SipReq: INVITE 91@192.168.4.4 tid=902fc0da76 cseq=INVITE contact=+31621201449@192.168.4.5:5060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings

    10:13:16.889 [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:

    INVITE sip:91@192.168.4.4 SIP/2.0

    Via: SIP/2.0/UDP 192.168.4.5:5060;rport=5060;branch=z9hG4bK902fc0da76

    Max-Forwards: 70

    Contact: <sip:+31621201449@192.168.4.5:5060>

    To: <sip:91@192.168.4.4>

    From: "+31621201449"<sip:+31621201449@192.168.4.4>;tag=56997f08

    Call-ID: 0232a87c4bd3660423ceb780587146dd@192.168.4.5

    CSeq: 2 INVITE

    Allow: INVITE, CANCEL, ACK, BYE, NOTIFY, REFER, OPTIONS, INFO, MESSAGE

    Proxy-Authorization: Digest username="10008",realm="3CXPhoneSystem",nonce="414d535c005bab9c91:de7ed6d9bd823b0f3f0c2208abe4ea9c",response="73495437be934093a9388c69bf3680be",uri="sip:91@192.168.4.4",algorithm=MD5

    Supported: replaces

    User-Agent: CM5K-TA1S (803060)

    Allow-Events: talk, hold, conference

    Content-Length: 0
     
  4. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Problem is fairly straight forward from the logs
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Pete-TPP

    Joined:
    Dec 31, 2006
    Messages:
    24
    Likes Received:
    0
    Well that is what I thought. Could you tell me what woul be the solution according to you? Because the GSM Gateway device IS registered. I can place calls but not recieve them. The uplink sends them to a receptionist but it seems to give a problem. I would not know where to register else. How could I make outgoing calls if the passwords would not match? It worked before and did not change this. The status also indicates registered. The receptionis I also use for two other lines and there it works. I refilled the password and username in the Gempro but still....
    \Do you have any other options?
     
  6. omnideas

    Joined:
    Jan 12, 2009
    Messages:
    5
    Likes Received:
    0
    Sometimes few of SIP server only accept SIP account as caller ID. so you may need to enter the system setting and set the CLID field the same with your SIP account in uplinK.


    TIM
     
Thread Status:
Not open for further replies.