GXW4104 caller id shows up as O

Discussion in '3CX Phone System - General' started by xenium, Jan 12, 2010.

Thread Status:
Not open for further replies.
  1. xenium

    Joined:
    Oct 5, 2009
    Messages:
    6
    Likes Received:
    0
    Having a weird problem with a Grandstream GXW4104. Most incoming caller id's work great, but randomly (not sure if it's certain numbers yet) it will just show up as the letter 'O'.

    I was told by some of the people in the office that it has showed up as O but still had the phone number (which usually it doesn't when it does this) and for one guy it once showed a P

    Anyone ever seen this? Search didn't turn up anything. Thanks
     
  2. jharrell

    Joined:
    Jun 23, 2009
    Messages:
    23
    Likes Received:
    1
    We have a GXW4104 and see the same exact behavior.

    I believe it is the 4104's fault as it is not decoding CID correctly.

    They just released a new firmware 1.3.1.6 that has listed in the fixes:

    "Fixed CID detection issue with Verizon PSTN line"

    We just happen to have Verizon PSTN lines. I haven't upgraded yet to see if it resolves the issue.
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,586
    Likes Received:
    252
    Bellcore type caller ID will send O for "out of area" calls, no number/name available, and a P for "Private Call" (blocked number). It is up to the caller ID device to interpret that and convert to a meaningful message. Try a call into the board while you block your number and see if you don't get a P.
     
  4. xenium

    Joined:
    Oct 5, 2009
    Messages:
    6
    Likes Received:
    0
    Thanks! That makes sense
     
Thread Status:
Not open for further replies.