handytone 503 configuration

Discussion in '3CX Phone System - General' started by giorgiobusoni, Jun 15, 2011.

Thread Status:
Not open for further replies.
  1. giorgiobusoni

    Joined:
    Apr 6, 2011
    Messages:
    32
    Likes Received:
    1
    Hello,
    i'm trying to cofigure the handytone 503 fxs/fxo gateway to work with 3CX
    I have also a snom 3 working with 3cx and works well
    but with handytone i have a problem configuring outgoing calls on PSTN line.

    here is the configuration:
    PSTN devices:
    genric - handytone 503
    ext: 10001
    incoming calls to: ext 11
    allow incoming calls
    allow outgoing calls

    voipprovider:
    generic
    incoming calls to: ext 10
    allow incoming calls
    allow outgoing calls

    ext:
    10: is the snom 3
    11: is the ext for the handytone

    outgoing rules:
    numbers starting with 0 or 3->generic voip provider
    numbers starting with 2->delete first digid and go to handytone 503 pstn

    in handytone config, i configured the FXS port with the account of ext 11 and FXO port with account of 10001
    primary server and outbound proxy both set to the 3cx server
    also set correct zone foor the impedence

    now, this is what happens:
    incoming calls to PSTN number go to phones connected to handytone->OK
    incoming calls on voip number go to snom ->OK
    outgoing calls starting with 0 or 3->done with voip account->OK
    outgoing calls starting with 2->one digit is removed but the call is not forwarded to the requested number, instead internal phones connected to handytone ring->NOT GOOD
    for example, i what to call 3925566778
    if i digit 3925566778 on the snom (ext10) and press the call button, a conversation between ext10 and the 3925566778 will start, using the vOIP number
    if i what to call the 3925566778 using PSTN line, i should digit 23925566778 on the snom (ext10), but in this case, a conversation between the snom(ext10) and the 3925566778 does not start, instead a conversation between the snom(ext10) and the the attacked to handytone (ext11) starts!!!!

    what's the error in my configuration?
     
  2. giorgiobusoni

    Joined:
    Apr 6, 2011
    Messages:
    32
    Likes Received:
    1
    this is the LOG:

     
  3. willow

    willow Member

    Joined:
    Mar 1, 2011
    Messages:
    471
    Likes Received:
    0
    make sure the stage dialing is set to 1 and not 2.

    also set the ring thru to fxs to no.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. giorgiobusoni

    Joined:
    Apr 6, 2011
    Messages:
    32
    Likes Received:
    1
    PSTN ring trough FXS was set to yes and stage dialing was set to 2. I fixed theese. tomorrow I try again and see if it solves the problem. I'll let you know
     
  5. willow

    willow Member

    Joined:
    Mar 1, 2011
    Messages:
    471
    Likes Received:
    0
    I just connect a handytone 503 to a 3cx. Its not the best piece of equipment but gets the job done for a line. If your in the states I can gladly help you out.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.