Handytone 503 Inbound Issue

Discussion in '3CX Phone System - General' started by djboxny, Nov 6, 2012.

Thread Status:
Not open for further replies.
  1. djboxny

    Joined:
    Aug 8, 2010
    Messages:
    42
    Likes Received:
    0
    I just gor my Handytone 503, My handytone is connected to the Copper line thru the FXO port. It is registered with 3cx as a PSTN Generic,

    Ok here is the issue. When i Dial the FXO line from a External number so it can ring thru 3cx, Who ever calls just gets a dial tone after 4 rings. 3cx doesnt even show anything in the log. On the status page of the Handytone it says Idle, even while i hear the phone ringing while calling from my cell phone to the Line that the FXO is connected too. Its acting like the phone is not ringing at all but after 4 rings it picks up and the caller hears a dial tone. I havent change any settings other than the default settings for SIP, User and password on the Handytone. After 4 Rings the and i hear a Dial tone i can even dial any extention of my 3cx system and it will ring. So wierd. All i want is the Handytone to accepts incoming calls and send them to my 3cx
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,362
    Likes Received:
    226
    In a nutshell, what has to happen, is the incoming call needs to "forward" to it's trunk group number, in 3CX. You may have to read through the 3CX configuration guides for other Grandstream products (gateways) to find similar menu pages, and the settings required to be changed. If you do a search through the forum, your model gateway has come up a few times.

    Worse case scenario is that you have to post the configuration pages, and we can suggest what need to be changed. Haven't used that model myself, but I have used an older, single line, Grandstream gateway.
     
  3. djboxny

    Joined:
    Aug 8, 2010
    Messages:
    42
    Likes Received:
    0
    I looked and searched. But theres no step by step. And the other grandstream fxo adapters dont have simmilar options
     
  4. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    Actually the 503 settings look quite similar to the gxw4104/8 settings.

    The first question is if the 503 is registered to 3cx as a VoIP gateway? The 4 rings you hear is a default setting that GS uses in order to give any callerid time to come through. This may also be a function of the ring thru to the fxs port which is also a default. Go to the Grandstream site, look for the gxw4104 product and then the knowledgebase or documents as they had a quick setup guide for manually getting the gxw connected to 3cx. Try those and see for the fxo settings.
     
  5. djboxny

    Joined:
    Aug 8, 2010
    Messages:
    42
    Likes Received:
    0
    The fxo port is the only one connected to my 3cx server. Registered as a pstn gateway. Port 10002. It shows registered fine as a gateqay in 3cx. Fxs is not registered. I wont use it until I get this workimg
     
  6. djboxny

    Joined:
    Aug 8, 2010
    Messages:
    42
    Likes Received:
    0
    OK just checked out the Configuration on the GrandStream GXW-4104 as you mentioned, Here is were i don't see this Option in the Handytone 503.


    From the GrandStream GXW-4104 configuration Guide
    http: //www.3cx.com/voip-gateways/Grandstream-GXW-41044108/ - NO LONGER AVAILABLE
    Click on the "FXO Lines" tab at the top of the page. Configure this page as follows:
    a. Set the “Stage Method” field to "ch1-4:1;"
    b. Set the "Unconditional Call Forward to VOIP" field to: "ch1-4:yyyyy+;" where yyyyy is the SIP User ID for the

    I still cant get this to work
     
  7. djboxny

    Joined:
    Aug 8, 2010
    Messages:
    42
    Likes Received:
    0
    OK got it to work. Setting to Forward calls to 3CX is in the Basic TAB. not the FXO tab. Hopefully this helps someone else with this issue
     
  8. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    Glad you got it to work.good luck on the fax.
     
Thread Status:
Not open for further replies.