Have to run 3CXWizard after every reboot

Discussion in '3CX Phone System - General' started by AndyC3PO, Apr 3, 2017.

Thread Status:
Not open for further replies.
  1. AndyC3PO

    Apr 3, 2017
    Likes Received:
    I have 3CX installed on Debian on an Intel NUC.

    This is a new installation, and it went relatively smoothly - a couple of minor mishaps with IP addressing/DNS servers that I performed a clean install on to resolve.

    My issue is that every time I reboot the box, I have to logon locally and run /usr/sbin/3CXWizard --cleanup
    This is even occurring after a fresh, perfectly executed install, and it's consistent - it never works after a reboot until I do this.

    When I try to access the web page in IE, I get page can not be displayed. When I try in Firefox I get a spinning bar followed by a "Server Error" message, behind which is a "DNS_NAMES_RESOLUTION" message (nothing more).

    I haven't even gotten to the point of activating this yet.

    Anybody have any suggestions on this?

  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    May 10, 2016
    Likes Received:
    Hello @AndyC3PO

    When you perform a reboot and the NUC machine comes back up do the phones register? I mean does the PBX work at all? It could be the case that the management console times out and does not start so you are not able to access the management console.
    After a reboot access the machine with SSH and check if all services are started (service 3CX* status) and let us know.
Thread Status:
Not open for further replies.