help configuring SN4114

Discussion in '3CX Phone System - General' started by kencarlin, Feb 21, 2012.

Thread Status:
Not open for further replies.
  1. kencarlin

    Joined:
    Feb 21, 2012
    Messages:
    3
    Likes Received:
    0
    I need some help with configuring my Patton SN4114. I am trying to configure it for use with a 3CX Phone System, and I'm afraid nothing that I do allows me to place an outgoing phone call on my POTS line.

    Here are my specifics:
    - I am using v10 of the 3CX Phone System, and we are registered.
    - They recommended using R5.7 2011-11-09 H323 SIP FXS FXO of the firmware, so that's what I'm currently using (although I have also tried the latest release)
    - I used the 3CX "Add Gateway" wizard to create my specific configuration file for the SN4114, which I successfully do import.

    I am able to receive phone calls on the POTS line just fine. The SN4114 routes to the Automated Attendant in 3CX. However, when I try to place an outgoing call, I get an error. From the 3CX log file:

    14:15:27.045|.\CallCtrl.cpp(529)|Log3||CallCtrl::eek:nSelectRouteReq:[CM503010]: Making route(s) to <sip:4127674111@192.168.1.5>
    14:15:27.046|.\CallCtrl.cpp(708)|Log2||CallCtrl::eek:nSelectRouteReq:[CM503004]: Call(44): Route 1: PSTNline:4127674111@(Ln.10000@PattonSN4114)@[Dev:sip:10000@192.168.1.3:5060,Dev:sip:10001@192.168.1.3:5062,Dev:sip:10002@192.168.1.3:5064,Dev:sip:10003@192.168.1.3:5066]
    14:15:27.093|.\Target.cpp(441)|Log2||Target::makeOneInvite:[CM503025]: Call(44): Calling PSTNline:4127674111@(Ln.10000@PattonSN4114)@[Dev:sip:10000@192.168.1.3:5060]
    14:15:27.976|.\Call.cpp(42)|Log3||??:Currently active calls - 1: [44]
    14:15:28.656|.\CallLeg.cpp(326)|Log2||CallLeg::eek:nFailure:[CM503003]: Call(44): Call to sip:4127674111@192.168.1.3:5060 has failed; Cause: 487 Request Terminated; from IP:192.168.1.3:5060
    14:15:28.665|.\Target.cpp(441)|Log2||Target::makeOneInvite:[CM503025]: Call(44): Calling PSTNline:4127674111@(Ln.10000@PattonSN4114)@[Dev:sip:10001@192.168.1.3:5062]
    14:15:28.914|.\CallLeg.cpp(326)|Log2||CallLeg::eek:nFailure:[CM503003]: Call(44): Call to sip:4127674111@192.168.1.3:5062 has failed; Cause: 502 Bad Gateway; from IP:192.168.1.3:5062
    14:15:28.923|.\Target.cpp(441)|Log2||Target::makeOneInvite:[CM503025]: Call(44): Calling PSTNline:4127674111@(Ln.10000@PattonSN4114)@[Dev:sip:10002@192.168.1.3:5064]
    14:15:29.170|.\CallLeg.cpp(326)|Log2||CallLeg::eek:nFailure:[CM503003]: Call(44): Call to sip:4127674111@192.168.1.3:5064 has failed; Cause: 502 Bad Gateway; from IP:192.168.1.3:5064
    14:15:29.179|.\Target.cpp(441)|Log2||Target::makeOneInvite:[CM503025]: Call(44): Calling PSTNline:4127674111@(Ln.10000@PattonSN4114)@[Dev:sip:10003@192.168.1.3:5066]
    14:15:29.430|.\CallLeg.cpp(326)|Log2||CallLeg::eek:nFailure:[CM503003]: Call(44): Call to sip:4127674111@192.168.1.3:5066 has failed; Cause: 502 Bad Gateway; from IP:192.168.1.3:5066
    14:15:29.431|.\Call.cpp(1091)|Log2||Call::RouteFailed:[CM503016]: Call(44): Attempt to reach <sip:4127674111@192.168.1.5> failed. Reason: Server Failure
    14:15:29.431|.\Call.cpp(605)|Log2||Call::DoEndCall:[CM503020]: Normal call termination. Reason: Server Failure


    Now I only have a phone line hooked up to port 0 as I test the system, so I do understand that 3 of the ports will properly report an error. However, I don't understand why I'm getting the "487 Request Terminated" error on port 0.

    I feel like I've tried every conceivable option to no avail, and I appreciate any help that you can offer me.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    Be sure that the phone line is actually connected to line one. Gateways will refuse to put a call out on a line if there is no voltage. Since you are getting the same rejection from line 2 on, and there is no phone line connected to those, you'd best double check line 1.
     
  3. kencarlin

    Joined:
    Feb 21, 2012
    Messages:
    3
    Likes Received:
    0
    That was actually one of the first things I checked. I've had two different phone cords plugged into the first line, and so far no joy.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    Are you located in North America? Others, that are not, have discovered that the wrong pins are being used (at the end of the cord) to work properly, when plugged into the RJ11 socket on the gateway.
     
  5. kencarlin

    Joined:
    Feb 21, 2012
    Messages:
    3
    Likes Received:
    0
    I am in North America, yes. I believe my phone cord is OK, since the system does receive calls perfectly fine. As a test, I have plugged a simple telephone directly into the same jack I'm trying to use for the 4114, and I am able to place calls.
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    If the gateway has a syslog server, then you may wish to make use of that. It may tell you why the gateway is not allowing the call to proceed.

    Here is a link to running a "trace" http://www.888voip.com/forum/patton/397-cid-on-patton-4114-a.html
     
Thread Status:
Not open for further replies.