Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Help, licence is suddenly not working

Discussion in 'CRM / Helpdesk / App Integration' started by millsey, Sep 26, 2013.

Thread Status:
Not open for further replies.
  1. millsey

    millsey New Member

    Joined:
    Dec 21, 2011
    Messages:
    203
    Likes Received:
    0
    Trying to run the VAD, getting

    An error occurred loading 3CX Voice Application Designer Licence:

    Licence could not be loaded from file 'c:\ProgramData\3CX Voice Application Designer\Licence\VADLicense.bin': Error licence :50 System:0

    Nothing has changed on this server and teh modified date for the licence file which is in place, is January 2013 so has not changed.
     
  2. VAD_Support

    VAD_Support Active Member

    Joined:
    Aug 6, 2009
    Messages:
    690
    Likes Received:
    0
    Hi Millsey,

    That error code means that the MAC address in the PC has changed. Did you install a new Ethernet card by any chance? Installed a virtual machine or anything that could add/remove a network card?

    In order to fix the problem if you can't revert the change, you can rename/remove the VADLicense.bin file and re-activate your license.

    Kind regards,
     
  3. millsey

    millsey New Member

    Joined:
    Dec 21, 2011
    Messages:
    203
    Likes Received:
    0
    Got you,

    We have just "teamed" two network cards together to give us a bigger link.

    Thanks for a quick reply. I have reactivated without problems.

    Millsey
     
  4. VAD_Support

    VAD_Support Active Member

    Joined:
    Aug 6, 2009
    Messages:
    690
    Likes Received:
    0
    If you rename the license file and re-activate, and get an error saying that the license is already active, then you need to manually change the registry as follows:
    1) Open regedit
    2) Go to HKEY_LOCAL_MACHINE\Software\Wow6432Node\3CX\VAD (in x64) or HKEY_LOCAL_MACHINE\Software\3CX\VAD (in x86) and remove the values "3CXVAD" and "Signature".
    3) Go to HKEY_LOCAL_MACHINE\Software\Wow6432Node\3CX\PhoneSystem (in x64) or HKEY_LOCAL_MACHINE\Software\3CX\PhoneSystem (in x86) and remove a value with strange name, for example "blnugvjvdrhsdlolpqdpflnnkvpuoskn". Warning: if this is the 3CX server, you will have a similar value for the VAD and another for 3CX Phone System. Removing the wrong value will deactivate the 3CX server license. So my recommendation is that you just rename this value, and rename it back if it was not the right one.
    4) After that, re-activate the license, it should work.

    Kind regards,
     
Thread Status:
Not open for further replies.