Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Help Please with 3cx No Voice

Discussion in '3CX Phone System - General' started by kevinmana, Aug 23, 2015.

Thread Status:
Not open for further replies.
  1. kevinmana

    Joined:
    Aug 23, 2015
    Messages:
    1
    Likes Received:
    0
    Hi All,

    I am new with 3cx pbx system. Here is my LAN: Internet -> mikrotik -> LAN

    mikrotik : 192.168.100.1
    3cx server IP : 192.168.100.184
    Port: 5000,5060,5090,10000-20000
    Phone Extention: 100 at Home, 200 at Laptop used from outside my LAN/Home

    Here is my mikrotik filter and nat
    /ip firewall filter
    add action=accept chain=forward disabled=no dst-address-list=protected_host \
    dst-port=5060,5090,10000-20000 protocol=udp
    add action=accept chain=forward disabled=no dst-address-list=protected_host \
    dst-port=5060,5090,5000 protocol=tcp

    /ip firewall nat
    add action=dst-nat chain=dstnat disabled=no dst-port=10000-20000 in-interface=\
    Internet protocol=udp to-addresses=192.168.100.184
    add action=dst-nat chain=dstnat disabled=no dst-port=5060,5090 in-interface=\
    Internet protocol=udp to-addresses=192.168.100.184
    add action=dst-nat chain=dstnat disabled=no dst-port=5060,5090,5000 \
    in-interface=Internet protocol=tcp to-addresses=192.168.100.184
    add action=masquerade chain=srcnat disabled=no src-address=192.168.100.0/24

    SIP 5060/5061 disable

    From 3cx pbx server I did firewall checker and all passed. ext 100 and 200 success registered.

    When i try to call from outsite my home using ext 200 to ext 100 or ext 999, i can not hear any voice.

    Please some one help me what i miss in here.

    Thank you
     
  2. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    813
    Likes Received:
    46
    Hi,

    I am not familiar with mikrotik but what I am missing is Port Forwarding of the RTP (audio) ports 9000-9199 UDP.

    SIP 5060/5061 are disabled and the firewall checker passes all tests?????

    Please read:
    http://www.3cx.com/blog/docs/ports-used/
    http://www.3cx.com/docs/firewall-router-configuration-voip/
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,073
    Likes Received:
    323
    The fact that you are not hearing audio at the remote end would suggest that the problem may be at that end. Normally, for a single device, no port forwarding is required at the remote end. I find that the more "complicated" the router in use, the more chance of problems If there is a firewall that is blocking some ports, then that may be the issue.

    Here is a list of all of the required ports at the 3CX PBX end...

    http://www.3cx.com/blog/docs/ports-used/

    And some additional reading...

    http://www.3cx.com/docs/firewall-router-configuration-voip/
     
  4. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,530
    Likes Received:
    298
    Mikrotik works quite well - as long as the proper ports are open as mentioned by others. Right off the bat I see the 9k range was not opened.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.