Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Help - randomly can't hear voice problem

Discussion in '3CX Phone System - General' started by xchen, Aug 1, 2014.

Thread Status:
Not open for further replies.
  1. xchen

    Joined:
    Aug 1, 2014
    Messages:
    8
    Likes Received:
    0
    when we call out, we don't hear the call ringing, and then the caller picks up, and we don't hear them speaking - but they claim they can hear us. If we hang up and try again, the call goes through and gets picked up, and everything is normal. It happens in reverse - someone rings us here, we pick up, can't hear a thing - then we or they hang up. They call again - and everything is fine. If it was once or twice, I wouldn't be too worried, but it's happened a bit in the past, and in the last couple of days, its happened on most calls in & out of the office. We've powered the phones down & up, but that's all I've tried, and doesn't seem to work. :(

    we are using Yealink phones:
    Firmware Version 7.60.0.110
    Hardware Version 5.0.0.55
     
  2. pj3cx

    pj3cx Active Member

    Joined:
    Aug 1, 2013
    Messages:
    646
    Likes Received:
    1
    Hi,
    What model of yealink phone are you using please?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. xchen

    Joined:
    Aug 1, 2014
    Messages:
    8
    Likes Received:
    0
    I think it is entry level one:
    IP Phone SIP-T20P
    Will double check next time in office (sorry, am from Australia and now 8pm on Friday).
     
  4. LukeyP

    Joined:
    Aug 1, 2014
    Messages:
    3
    Likes Received:
    0
    Please try ticking the 'PBX delivers Audio' setting and if you have HP switches, please turn of LLDP.
    I had both these issues in the past.

    Cheers
     
  5. xchen

    Joined:
    Aug 1, 2014
    Messages:
    8
    Likes Received:
    0
    I have just done the changes as suggested, and will report back with the outcome.

    We don't have HP switch, it is a netgear switch, so guess would be no action needed.

    Thanks mate!
     
  6. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    815
    Likes Received:
    49
    The firmware version you are using is very old, I think.
    Also it starts with “7” and this will say you are using the Yealink T22P phone, not the T20P.
    May I suggest to update the firmware to the by 3CX supported version 7.71.0.224
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. naked

    Joined:
    Oct 18, 2013
    Messages:
    8
    Likes Received:
    0
    Hi,
    I expect that you have done this, but make sure that the firewall check is OK. Port forwarding must be right, otherwise you do get one way audio.

    Also it is true that you need to update your firmware. We find that the later Yealink firmware is a lot better.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. VoidRunner

    Joined:
    Aug 6, 2014
    Messages:
    7
    Likes Received:
    0
    The one way audio usually is a problem related with the RTP protocol, and more precisely with the Network Package Delivery from host to host, which is a network issue.
    Do you have any VPN Tunnels between the extensions and the server?
    You may observe the 3CX logs (all of them). and watch for RTP word, saying unable to deliver audio to Host IP Address.
    I've similar situation one or two years ago and fixed it by defining a static RTP port.

    Greetings
     
  9. xchen

    Joined:
    Aug 1, 2014
    Messages:
    8
    Likes Received:
    0
    Since I ticked the "PBS delivers Audio" for those extensions from 3CX server, those phones don't have this problem any more. Seems it does the trick! Thanks!
     
  10. xchen

    Joined:
    Aug 1, 2014
    Messages:
    8
    Likes Received:
    0
    Thanks for bringing up the firmware version issue. I didn't think of this before. Will upgrade them to latest version!
     
  11. xchen

    Joined:
    Aug 1, 2014
    Messages:
    8
    Likes Received:
    0
    Awesome! Sounds complicated. Hopefully we don't have RTP problem, but will keep in mind. Thanks!
     
Thread Status:
Not open for further replies.