Help with new setup

Discussion in '3CX Phone System - General' started by rizwan602, Jun 16, 2009.

Thread Status:
Not open for further replies.
  1. rizwan602

    Joined:
    Jun 16, 2009
    Messages:
    3
    Likes Received:
    0
    Hello,

    I am test driving 3cx free edition (with intention to upgrade to paid edition if it works for us). I have been up and running in a limited sense now -- I am using voip.ms as the sip trunk and can make outgoing calls but there is no audio in the calls, specifically when placing a call to any destination (PSTN or another VOIP provider) I can not hear anything that is said on the other side. I can send DTMF tones from my side and the other party can hear them. I am using the 3cx soft client and also tried Counterpath X-10 and same problem.

    My server is behind a firewall (Not a NAT but an actual firewall) and has a public ip address. I opened up the appropriate ports (5060, etc...) and ran the firewall checker and it reported no issues.

    I can not figure this out -- please help! Thank you!
     
  2. bluetel2

    bluetel2 Member

    Joined:
    Oct 16, 2008
    Messages:
    377
    Likes Received:
    6
    hello Rizwan.

    Wihout log file it's difficulte to analyse your problem 8) . can you send the log file please.

    are you sure the stunt works ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. mbaltus

    Joined:
    Dec 12, 2008
    Messages:
    66
    Likes Received:
    0
    Can you try if you have audio when you set "PBX delivers Audio" in one of the extensions. It is likely that 3CX hands of the call to the VOIP phone and that NAT-ing than occurs. Perhaps if you let 3CX handle the audio it will work.
    After that, a NAT solution can be implemented if you prefer 3CX not to route all audio.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. rizwan602

    Joined:
    Jun 16, 2009
    Messages:
    3
    Likes Received:
    0
    Hello,

    The firewall checker reports no problems. The server is NOT behind a NAT, it has a public ip address. There is a firewall in place but all ports that the system uses to the best of my knowledge are open.

    Here is a copy of the log file from a restart to a call being made with no incoming audio:


    01:33:20.544 SL: connected sipserver1:0/3CXConferenceRoom at [sipserver1]/3CXConferenceRoom

    01:33:18.812 [CM503008]: Call(1): Call is terminated

    01:33:18.772 [CM503008]: Call(1): Call is terminated

    01:33:17.390 SL: connected sipserver1:0/3CXParkOrbit at [sipserver1]/3CXParkOrbit

    01:33:16.608 [CM112000] Media Server is connected

    01:33:16.608 SL: connected sipserver1:0/MediaServer at [sipserver1]/MediaServer

    01:33:15.617 SL: connected sipserver1:0/IVRServer at [sipserver1]/IVRServer

    01:33:11.691 SL: disconnected sipserver1:0/3CXConferenceRoom at [sipserver1]/3CXConferenceRoom

    01:33:07.355 [CM504010]: Fax Service: unregistered contact sip:888:5100;user=phone

    01:33:06.904 Session 24 of leg C:1.1 is confirmed

    01:33:06.834 [CM504010]: Fax Service: unregistered contact sip:888:5100;user=phone

    01:33:06.644 [CM503007]: Call(1): Device joined: sip:102048_005@sip.us4.voip.ms:5060

    01:33:06.604 [CM503007]: Call(1): Device joined: sip:201@70.171.244.154:21207;rinstance=1dd023a2bae072bc

    01:33:06.103 SL: disconnected sipserver1:0/3CXParkOrbit at [sipserver1]/3CXParkOrbit

    01:33:04.211 [CM505003]: Provider:[voip.ms] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [VoIPMS/SERAST] Transport: [sip:167.157.129.100:5060]

    01:33:04.211 [CM503002]: Call(1): Alerting sip:102048_005@sip.us4.voip.ms:5060

    01:33:02.779 [CM503024]: Call(1): Calling VoIPline:6024374777@(Ln.10000@voip.ms)@[Dev:sip:102048_005@sip.us4.voip.ms:5060]

    01:33:02.769 [CM503004]: Call(1): Route 1: VoIPline:6024374777@(Ln.10000@voip.ms)@[Dev:sip:102048_005@sip.us4.voip.ms:5060]

    01:33:02.678 [CM503010]: Making route(s) to "6024374777"<sip:6024374777@167.157.129.100>

    01:33:02.678 [CM505001]: Ext.201: Device info: Device Identified: [Man: Counterpath;Mod: X-Lite;Rev: General] Capabilities:[reinvite, no-replaces, unable-no-sdp, recvonly] UserAgent: [X-Lite release 1100l stamp 47546] Transport: [sip:167.157.129.100:5060]

    01:33:02.558 [CM503001]: Call(1): Incoming call from Ext.201 to "6024374777"<sip:6024374777@167.157.129.100>

    01:33:02.538 [CM500002]: Info on incoming INVITE:

    INVITE sip:6024374777@167.157.129.100 SIP/2.0

    Via: SIP/2.0/UDP 192.168.127.195:34918;branch=z9hG4bK-d8754z-3735be7093106e09-1---d8754z-;rport=21207;received=70.171.244.154

    Max-Forwards: 70

    Contact: <sip:201@70.171.244.154:21207>

    To: "6024374777"<sip:6024374777@167.157.129.100>

    From: "201"<sip:201@167.157.129.100>;tag=9c6ba40e

    Call-ID: ZTY3MDA5NTk2MDA1M2VhODQ2MDRiNmRhMzEyMzQxODQ.

    CSeq: 2 INVITE

    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, NOTIFY, MESSAGE, SUBSCRIBE, INFO

    Proxy-Authorization: Digest username="201",realm="3CXPhoneSystem",nonce="414d535c004bde3e45:d463db09d5cb4901aa602b1b22bf9d27",uri="sip:6024374777@167.157.129.100",response="890dc30e58e1ca69a1d4eefe2c51c91b",algorithm=MD5

    User-Agent: X-Lite release 1100l stamp 47546

    Content-Length: 0




    01:33:00.325 SL: disconnected sipserver1:0/MediaServer at [sipserver1]/MediaServer

    01:33:00.315 *** Server shut down ***

    01:33:00.295 *** Exit Listen ***

    01:33:00.295 *** Server started ***

    01:32:54.747 [CM504001]: Ext.201: new contact is registered. Contact(s): [sip:201@70.171.244.154:21207;rinstance=1dd023a2bae072bc/201]

    01:32:54.056 [CM504002]: Ext.201: a contact is unregistered. Contact(s): []

    01:32:53.625 [CM504001]: Ext.201: new contact is registered. Contact(s): [sip:201@192.168.127.195:34918;rinstance=d364cb4ba76216cb/201]

    01:32:53.555 [CM504002]: Ext.201: a contact is unregistered. Contact(s): []

    01:32:37.142 [CM504002]: Ext.201: a contact is unregistered. Contact(s): []

    01:32:36.611 [CM504002]: Ext.201: a contact is unregistered. Contact(s): []

    01:32:05.276 [CM504001]: Ext.*1: new contact is registered. Contact(s): [sip:*1@127.0.0.1:40000;rinstance=c70d846b4b98e368/*1]

    01:32:04.985 [CM504001]: Ext.*0: new contact is registered. Contact(s): [sip:*0@127.0.0.1:40000;rinstance=df87f92abca115a6/*0]

    01:31:56.934 [CM504004]: Registration succeeded for: 10000@voip.ms

    01:31:54.671 [CM504003]: Sent registration request for 10000@voip.ms

    01:31:54.320 IP(s) added:[167.157.129.100]

    01:31:53.449 [CM504008]: Fax Service: registered as sip:888@167.157.129.100:5060 with contact sip:888@167.157.129.100:5100;user=phone

    01:31:52.517 [CM504004]: Registration succeeded for: 10000@voip.ms

    01:31:49.463 SL: connected sipserver1:0/3CXConferenceRoom at [sipserver1]/3CXConferenceRoom

    01:31:49.303 [CM504003]: Sent registration request for 10000@voip.ms

    01:31:47.961 SL: connected sipserver1:0/3CXParkOrbit at [sipserver1]/3CXParkOrbit

    01:31:47.901 [CM112000] Media Server is connected

    01:31:47.901 SL: connected sipserver1:0/MediaServer at [sipserver1]/MediaServer

    01:31:46.729 [CM506002]: Resolved SIP external IP:port (167.157.129.100:5060) on Transport 167.157.129.100:5060

    01:31:46.569 [CM506001]: STUN request to resolve SIP external IP:port mapping is sent to STUN server 75.101.138.128:3478 over Transport 167.157.129.100:5060

    01:31:44.246 [CM501007]: *** Started Calls Controller thread ***

    01:31:44.236 [CM501006]: Default Local IP address: [167.157.129.100]

    01:31:44.226 [CM501002]: Version: 7.1.7060.0

    01:31:44.226 [CM501001]: Start 3CX PhoneSystem Call Manager

    01:31:41.942 Unknown system [DBProvider] tries to connect!

    01:31:41.942 SL: connected sipserver1:5485/DBProvider at [sipserver1]/DBProvider
    01:31:41.852 [CM501010]: License Info: Load Failed
     
  5. mbaltus

    Joined:
    Dec 12, 2008
    Messages:
    66
    Likes Received:
    0
    And what happens when you set try to ste "PBX delivers Audio" in one of the extensions and use that one.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. rizwan602

    Joined:
    Jun 16, 2009
    Messages:
    3
    Likes Received:
    0
    Well I can make a call, the call connects, the other party answers but I can not hear them. I can send DTMF to them.

    I am calling my work in this example and the 3cx softphone shows connecting and then its connected. If I press 233 for example it will ring extension 233 at the office. I know that much is working. But I do not hear anything in this call. It just goes silent as soon as its connected. The audio on the computer where the softphone is is working because I can hear the dialtone and the numbers I press.

    I tried the "pbx delivers audio" but no luck.

    I am using voip.ms -- in the voip provider wizard I used a "generic voip provider". Should I use "generic voip trunk" or something like that?

    But I dont understand the no audio thing especially since the firewall checker has "0" problems...

    Thanks for the help!
     
Thread Status:
Not open for further replies.