Hide id of outgoing call

Discussion in '3CX Phone System - General' started by ccuomo, Oct 29, 2016.

Thread Status:
Not open for further replies.
  1. ccuomo

    Joined:
    Oct 29, 2016
    Messages:
    5
    Likes Received:
    0
    Greetings to all the forum,

    i installed 3CX on Windows 10. I have to hide the caller id of a single extension, but do not know where to make the action.

    Carry a simple schematic:
    Grandstream 1620 -> 3cx ---> cisco spa232 ---> isdn :oops:
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,766
    Likes Received:
    286
    The default code (prefix) to block caller ID is *5. However, they would have to remember to use this each time. If your provider has a code used to block caller ID, you could create a separate outbound rule, only used by that one extension, and prefix the required digits. Then your provider would suppress the number.
     
  3. aberry

    aberry New Member

    Joined:
    Jan 13, 2015
    Messages:
    118
    Likes Received:
    7
    I also have a group that wants outgoing caller ID suppressed. I contacted the SIP provider for the dialing code to block, and created an outgoing rule for those extensions. Worked great.
     
  4. briankayser

    Joined:
    Jul 19, 2016
    Messages:
    49
    Likes Received:
    5
    Many phones allow you to add a prefix to all calls. This would require you to directly modify the phone's settings outside of 3CX but if you are only needing to do this on a few phones it shouldn't be a big deal.

    On a Grndstream 2160 (for example) under ACCOUNTx\Call Settings in the phone's web interface, you can put *5 in the "Dial Plan Prefix". With this it adds the *5 on every call. I just tested this. Even though it adds *5 to internal calls too, the remote extensions still show your name/ext (which I think you would want) but on on external call it shows as anonymous.

    You could also try putting "Anonymous" in for the extension's "Outbound Caller ID". Some SIP provides don't like that though.

    You will want to keep e911 in mind in whatever you do, even if you put a sticker on the phone that says it doesn't have 911 services.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. ccuomo

    Joined:
    Oct 29, 2016
    Messages:
    5
    Likes Received:
    0
    According to the trace the phone is sending correctly the INVITE with "anonymous" and getting '403 Forbidden' with message 'Caller Is Forbidden' from the 3CX Server, can you please check this from the server side, and let me know.


    Please check if there is any option to accept Anonymous Calls on 3CX, since the server ignores those requests. If you assume other phones are able to dial with anonymous to the same server, please let me know, and provide with a trace accordingly, otherwise, please check why the server is forbidding the anonymous caller.
     
  6. JasonNadeau

    JasonNadeau Member

    Joined:
    Oct 14, 2015
    Messages:
    262
    Likes Received:
    46
    You need to be more specific here. You got the right advise above.
    It seems as though you're now suddenly talking about incoming anonymous calls
    even though your original request was how to make outgoing calls with a blocked callerID.
    ... so what are you trying to do ? Accept anonymous calls (nothing to do), or MAKE anonymous calls.
    If you're trying to make it and getting that "403 forbidden" message, that's most likely not from the PBX but from your sip provider, OR you don't have the proper outbound rules set. What are you dialing that's giving you that message ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. ccuomo

    Joined:
    Oct 29, 2016
    Messages:
    5
    Likes Received:
    0
    the problem occurs with outgoing calls
     

    Attached Files:

  8. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    421
    The invite coming from your phone to the PBX is invalid that is the reason the PBX sends back Forbidden.
    2017-03-22_11h59_01.png
    The extensions is allowed to send Anonymous in the first part but the sip:<> part should be the extension number and the part after the @ should be the domain the phone is a part off (the pbx host name or ip).
     
  9. ccuomo

    Joined:
    Oct 29, 2016
    Messages:
    5
    Likes Received:
    0
    This is the response of the Grandstream support

    Hi,


    I just run several tests in our lab, i tested with our phones, and OTHER BRANDS as well, the From Header is always sent in the format you have attached, and the 3CX Server is always forbidding the caller with "403 Forbidden" and "Caller is Forbidden" message.

    I have tested on other PBXs and they accept correctly the anonymous calls with that format.

    Please check if there is any option to accept Anonymous Calls on 3CX or why exactly the calls are being forbidden from different brands. If you assume other phones are able to dial with anonymous to the same server, please let me know, and provide with a trace accordingly, it will be very helpful for us to see the right anonymous FROM header format that 3CX server accepts.

    Thank you.
    Best Regards,
    Driss
     
    #9 ccuomo, Mar 22, 2017
    Last edited: Mar 22, 2017
  10. ccuomo

    Joined:
    Oct 29, 2016
    Messages:
    5
    Likes Received:
    0
    I can not understand how I can enter the dial plan the character #

    my dial plan is this:
    (* Xx | [3469] 11 | 0 | 00 | [2-9] xxxxxx | 1xxx [2-9] xxxxxxS0 | xxxxxxxxxxxx.)

    if you call the number *67#3451245123

    pbx comes on

    *67%23451245123

    How can I fix?
     
Thread Status:
Not open for further replies.