Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Hide inbound area code and prepend a 0

Discussion in '3CX Phone System - General' started by martijnk0, Aug 29, 2011.

Thread Status:
Not open for further replies.
  1. martijnk0

    Joined:
    Aug 29, 2011
    Messages:
    5
    Likes Received:
    0
    Hello,

    I'm experimenting with 3CX and I run into a problem.
    If I receive a call on my VOIP phone the Caller ID is shown as 0031XXXXXXXXX,
    format as 0031 (country code - of The Netherlands) - (area code without 0) - (phone number).

    Now I want to hide 0031 and add a 0 so I can use my recall button on the phone.

    Do you have ideas?

    Thanks.
     
  2. nbailey

    nbailey Member

    Joined:
    Jan 31, 2011
    Messages:
    359
    Likes Received:
    0
    Hello,

    This is possible if you correctly setup the e164 dialing in the 3CX Management console. What this does is tell the PBX what its location is. This is found under Settings > Advanced and the first tab e164 number processing. By setting this up correctly 3CX will determine when you hit redial how to process the number, is it local, long distance etc. Hope this helps.

    Thanks,
    Nate
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. martijnk0

    Joined:
    Aug 29, 2011
    Messages:
    5
    Likes Received:
    0
    My settings:


    But I stil see the Caller ID 0031 ...
     

    Attached Files:

    • 3cx.PNG
      3cx.PNG
      File size:
      8.9 KB
      Views:
      1,004
  4. nbailey

    nbailey Member

    Joined:
    Jan 31, 2011
    Messages:
    359
    Likes Received:
    0
    how do you mean you see it? when you hit redial? The number is processed when you hit send and 3CX checks it against the e164 dialing rules not when you hit redial and see the number on your phone's display.

    or

    you can add an outbound rule that says I dial 0031 or whatever, strip 3 digits and add a 0.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. martijnk0

    Joined:
    Aug 29, 2011
    Messages:
    5
    Likes Received:
    0
    When I call from my house line to my VoIP provider I see on my screen the 0031 ..
    I would like to hide that so I can redial en use my phonebook.
     
  6. nbailey

    nbailey Member

    Joined:
    Jan 31, 2011
    Messages:
    359
    Likes Received:
    0
    What I just mentioned will do this, it will still show on your phone but in processing the number before it dials the 0031 will be stripped and a 0 will be added. BUT you will still see the 0031 when you hit redial but it will work.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. martijnk0

    Joined:
    Aug 29, 2011
    Messages:
    5
    Likes Received:
    0
    Ok,
    I'll try that, but i prefer a other way because when I add a number to the phone book in my VoIP phone, I need to prepend 0031 for every number.
     
  8. nbailey

    nbailey Member

    Joined:
    Jan 31, 2011
    Messages:
    359
    Likes Received:
    0
    you shouldn't have to do that. 3CX has outbound rules for a reason, setting up outbound rules is the quickest and easiest way for this to be accomplished. If you need to add 0031 to certain numbers you can create an outbound rule for that as well. No need to type long crazy numbers in your phone book when a clear and accurate set of outbound rules will do the trick.

    Thanks,
    Nate
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. martijnk0

    Joined:
    Aug 29, 2011
    Messages:
    5
    Likes Received:
    0
    Ok, but the caller ID wouldn't work if I don't add 0031 to my contacts in the phone book (on the VoIP phone).
    Then: If a person calls the 0031... number is displayed.
     
Thread Status:
Not open for further replies.