Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Hold music not working

Discussion in '3CX Phone System - General' started by bonezAU, Mar 17, 2018.

Thread Status:
Not open for further replies.
  1. bonezAU

    Joined:
    Oct 17, 2017
    Messages:
    12
    Likes Received:
    0
    I'm using the latest version 15.5 with the newest service pack. Recently we've noticed that music on hold just stops working for no reason. The configuration hasn't changed, nor has the .wav files we're using. They are in the correct format, and the 3CX Audio Provider service is running normally.

    It's installed on a Windows server, and sometimes we reboot it and the hold music starts working again, other times it reboots and still no hold music. That's where I am at now. I've rebooted it twice already today but still no hold music either when putting a call on hold, parking it, or during a transfer. We also have an voice app with an IVR in one of our departments, and when I call it from outside (my cell phone) and press 4, it should transfer me to an extension, while waiting for that person to pick up their phone, all I get is silence, not hold music as I should normally hear when the system is working correctly.

    Can anyone point me in the right direction here in terms of what logs I should be looking at to try and narrow down the problem? We have the Pro edition so are paying for support, but it seems they really want to push you to the reseller (which isn't open on weekends), and it's not often I get a chance to sit down outside of our business hours where I can take the system offline to troubleshoot without impacting anyone.

    I'm at a loss as to why it works sometimes and other times not. We have a test/dev system set up and the hold music works every single time, I have not experienced this issue in our test/dev environment at all, only production. We're using the exact same .wav files in both systems.

    I should also note that if I change the hold music from our custom files to the built in 3CX hold music files, it doesn't make any difference, so that rules out our .wav files being the culprit. Before we even set up our files, we read the guide about converting wav and made sure it was within spec, and because it sometimes works we know that the files are in the correct format and are not the issue.

    There seems to be something going on within 3CX that just randomly decides it doesn't want to play hold music and I'd like to be able to find out why.

    Cheers
     
Thread Status:
Not open for further replies.