Hold /Resume, hold music stuck

Discussion in '3CX Phone System - General' started by Nick@Troosters, May 14, 2013.

Thread Status:
Not open for further replies.
  1. Nick@Troosters

    Joined:
    Nov 12, 2012
    Messages:
    22
    Likes Received:
    0
    Hello,

    a client of mine has the following problem :
    a person calls to them, (the persons comes in a queue) ; client picks up the Phone and talks , then clicks on transfer;
    the person hears a waiting music now;
    client calls a cllegue, but the collegue does not answer so she ends that call and clicks on resume to take back the person who is calling in;
    the person is still hearing the hold music.
    So basically the call cannot be resumed and has to be ended.

    in the logs I saw this :

    NAT/ALG check:L:349.3[Extn] REQUEST 'INVITE' - some of SIP/SDP headers may contain inconsistent information or modified by intermediate hop
    Media session IP ('c=' attribute) is not equal to the IP specified in contact header:
    Media session IP:0.0.0.0
    Contact IP:10.0.0.212
    Media session IP ('c=' attribute) is not equal to the SIP packet source(IP:port):
    Media session IP: 0.0.0.0
    Received from: 10.0.0.212

    I think this is concerning the problem, but what does it mean and how can I fix this ??
     
  2. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    2,978
    Likes Received:
    183
    Do you have multiple IP interfaces on the phone server? If so, ensure yo uare using just one.
    When you resume the call, can you talk to the person - or all they have is the hold music?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Nick@Troosters

    Joined:
    Nov 12, 2012
    Messages:
    22
    Likes Received:
    0
    Hello,
    no there is only one ip on the server 10.0.0.11,
    The person keeps hearing the hold music.
     
  4. mlump

    mlump New Member

    Joined:
    Feb 24, 2012
    Messages:
    113
    Likes Received:
    0
    What Version of 3CX are you running?
    What phones are you using?
    Is this happening with a remote phone or one on the local LAN?

    The ALG check failing typically indicates that there is a SIP ALG sitting between the ext and the 3CX server.
     
Thread Status:
Not open for further replies.