Hosted 3CX wont allow outbound calls on Gamma Sip Trunk

Discussion in '3CX Phone System - General' started by Paul Brennan, Jan 22, 2018.

Thread Status:
Not open for further replies.
  1. Paul Brennan

    Joined:
    Jan 22, 2018
    Messages:
    4
    Likes Received:
    0
    Hi,

    I have a 3CX instance that has been hosted by 3CX with Gamma and I am not able to make outbound calls. All other features including internal and inbound calls are connecting normally.

    From the logs i get a 404 result as I believe that the wrong details are being passed. I have not been able to find what the correct settings would be for a Gamma Trunk despite extensive searching and a lot of trial and error.
    Can anyone confirm what the Outbound Parameters would be?

    Many thanks,
     
  2. Paul Brennan

    Joined:
    Jan 22, 2018
    Messages:
    4
    Likes Received:
    0
    The log shows:

    has failed. 35.25.**.** replied: 404 User unknown.; from IP:35.25.**.**:5060
     
  3. mixig

    mixig Active Member

    Joined:
    Dec 13, 2011
    Messages:
    519
    Likes Received:
    11
    Check number format for dialed number, maybe your provider is expecting dialed number in different format
     
  4. eddv123

    eddv123 Active Member

    Joined:
    Aug 15, 2017
    Messages:
    900
    Likes Received:
    137
    Very little should need to be changed as it is a templated/supported trunking provider.

    I have used Gamma before and at one point had to change the "Put Public IP in SIP VIA Header" but this was due to a network configuration problem.

    Bit of a basic question but I do not see anything mentioned in your initial email - do you have an Outbound rule setup for this trunk - and ensure that your first route is not set to "BLOCK CALLS".
     
  5. Paul Brennan

    Joined:
    Jan 22, 2018
    Messages:
    4
    Likes Received:
    0
    Hi,
    The number format comes through with the format ie. 02071112233.

    Yes i have an outbound Rule that I have copied from a different 3CX build on a different Sip Trunk which is able to make outbound calls with no problem.
    upload_2018-1-22_11-33-0.png

    Thanks,
     
    #5 Paul Brennan, Jan 22, 2018
    Last edited by a moderator: Jan 22, 2018
  6. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,392
    Likes Received:
    279
    Hello @Paul Brennan

    Please note that Gamma is a supported provider and the template included in the management console is correctly configured with all the necessary settings for Gamma. With that in mind i would recommend deleting the trunk and re-adding it to make sure that all settings the the default ones. If you still cannot perform outbound calls then navigate to trunk settings / Options and make sure that the option "Put Public IP in SIP VIA Header" is enabled and the correct public IP is populated in the field.
     
  7. Paul Brennan

    Joined:
    Jan 22, 2018
    Messages:
    4
    Likes Received:
    0
    I have rebuilt the sip Trunk twice and left the settings as per default and i can confirm the correct external IP address is set for the SIP Header. I am still having the same issue.
    I have spoken to Gamma and they have advise that they are not seeing the call on their logs so it appears that the call is not reaching them.

    Thanks.
     
  8. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,392
    Likes Received:
    279
    Are you seeing any errors in the activity log of the PBX when you try to make a call? You may need to set the logging level to verbose and restart services in order to capture more details about the issue. You could also run a wireshark and check if the call is leaving the server.
     
Thread Status:
Not open for further replies.