Hosted Multitenant 'call rejected' when using DNS name

Discussion in 'Windows' started by purpleone, Mar 27, 2012.

Thread Status:
Not open for further replies.
  1. purpleone

    Joined:
    Mar 18, 2009
    Messages:
    18
    Likes Received:
    0
    I'm currently testing the new Multi tenant version of 3cx, works great. As its a hosted system ALL extensions register externally and use STUN.

    If on the server under 'Public IP' I set it as its physical IP address and then register the handset (in this case I'm using the 3CX for iPhone), everything works fine - incoming and outgoing calls work.

    But, if the 'Public IP' is set to the servers external DNS name, and the phone registers using the DNS name, the phone can receive calls, but outgoing calls show the below error:


    23:50:45.459 [CM502001]: Source info: From: "DemoPBX"<sip:5567@dns.dnsname.com:14060>;tag=ZusG3SnRdMNjF85psB7bcW2bR-.3yuP8<sip:0411134007@dns.dnsname.com:14060>
    23:50:45.459 [CM503013]: Call(3): Incoming call rejected, caller is unknown; msg=SipReq: INVITE 0411XXXXXX@dns.dnsname.com:14060 tid=PjIPVthsGgd.lZaoq1ENLtVhBioG-0PZer cseq=INVITE contact=5567@114.xxx.xxx.xxx:57036 / 27590 from(wire)
    23:50:45.301 [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:0411XXXXXX@dns.dnsname.com:14060 SIP/2.0
    Via: SIP/2.0/UDP 114.xxx.xxx.xxx:57036;rport=57036;branch=z9hG4bKPjshwrekA2a4G8mYsZCpBos41E2I9YajyR
    Max-Forwards: 70
    Contact: "DemoPBX"<sip:5567@114.xxx.xxx.xxx:57036;ob>
    To: <sip:0411XXXXXX@dns.dnsname.com:14060>
    From: "DemoPBX"<sip:5567@dns.dnsname.com:14060>;tag=ZusG3SnRdMNjF85psB7bcW2bR-.3yuP8
    Call-ID: AW6GtJwvQVlJZoURY6dZ5b6FBOevDANk
    CSeq: 27589 INVITE
    Session-Expires: 1800
    Min-SE: 90
    Allow: PRACK, INVITE, ACK, BYE, CANCEL, UPDATE, SUBSCRIBE, NOTIFY, REFER, MESSAGE, OPTIONS
    Supported: replaces, 100rel, timer, norefersub
    User-Agent: 3CXPhone for iPhone 1.1.4
    Content-Length: 0


    Can anyone see what might be causing the issue?
     
  2. purpleone

    Joined:
    Mar 18, 2009
    Messages:
    18
    Likes Received:
    0
    Found the problem. I had added the setting for DNS in 'Public IP' under Network, but also have to add the DNS setting for 'Local SIP domain' under advanced.

    Hope this helps some one else.
     
Thread Status:
Not open for further replies.