Hosted Setup...incoming yes, outgoing NO!

Discussion in '3CX Phone System - General' started by Lenardb79, Mar 20, 2018.

Thread Status:
Not open for further replies.
  1. Lenardb79

    Joined:
    Mar 16, 2018
    Messages:
    2
    Likes Received:
    0
    I have the google hosted setup with callcentric as our provider. Incoming calls no issue, but we have for testing a windows 10 softphone and an android softphone. I have a GXV3140 (used on a 5 yr old on-premise version of 3cx and it worked then) but will not provision now...but ill deal with that next.

    I set the outgoing rules as I am used to and as per the 3cx manual and callcentric/3CX (they support 3cx) and still no go.

    Ideas?

    anyone with callcentric and 3cx can give me their outgoing setup or any other advice.

    BTW...the softphones just upon hitting dial, say "Declined" all I want is strip the +1 and then dial 9 and the 10 digit # im calling. while still allowing for me to dial the 3 digit extensions wit now issue
     
  2. mariosM_3CX

    mariosM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    376
    Likes Received:
    35
    Hello @Lenardb79

    It might be that the call is not matching any outbound rule. Check your activity log for more info as to why the call is declined.
    Also, make sure that in the extension settings >> Options you did not enable the option to disable external calls.
    Can you share a screenshot of your outbound rules and format of the number you are dialing?
     
    JCLloyd likes this.
  3. Sampl

    Joined:
    Jan 4, 2018
    Messages:
    20
    Likes Received:
    4
    are the Caller ID fields filled in on the extensions?
     
  4. Lenardb79

    Joined:
    Mar 16, 2018
    Messages:
    2
    Likes Received:
    0
    upload_2018-3-20_16-29-21.png upload_2018-3-20_16-29-21.png

    when I copy/paste logs and try to post it says I am trying to post spam....:(

    I do not have an extension > then, Options area...now under extensions, I do not see anything that says under any tab "disable external calls" or similar

    ...and yes Outbound Caller Id is filled in, should I leave empty?
     
  5. Saqqara

    Saqqara Active Member

    Joined:
    Mar 12, 2014
    Messages:
    699
    Likes Received:
    99
    Try removing the + sign from the prefix, as I am guessing your outgoing calls do not have + sign - activity log will confirm this

    Instead of the + sign on the prefix, add one extension number into the extension field to see if this works.

    I would say you need to setup your outbound rules correctly, https://www.3cx.com/docs/manual/outbound-rules/

    If the number being dialled does not match any of the outbound rules, the call will fail - any failures look in the activity log to see the format of the number being dialled.
     
    #5 Saqqara, Mar 21, 2018
    Last edited: Mar 21, 2018
  6. Sampl

    Joined:
    Jan 4, 2018
    Messages:
    20
    Likes Received:
    4
    Nope that is good :). I remember having this very issue, was able to receive but not call out. the issue was that there was no number in the caller ID field that was registered on the trunk so it couldn't resolve.
     
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,098
    Likes Received:
    203
    I'm with Saqqara. Simplify your outbound rules using only numeric characters, to see if that works. hen later , incorporate additional rules that make use of + and convert to the international/national prefix. Post an Activity Log of a failed call so we can see how far it gets.
     
Thread Status:
Not open for further replies.