How do I allow a remote softphone or IP phone connect?

Discussion in '3CX Phone System - General' started by Socrates, Aug 9, 2007.

  1. Socrates

    Joined:
    Aug 9, 2007
    Messages:
    4
    Likes Received:
    0
    Noob here.

    I need to set up an SIP Softphone in a cell phone to connect to the 3CX IP PBX. I have a dynamic domain name and I have a dlink di-624 router between the 3CX and the Internet.

    In other words from a wifi cell (or any remote SIP device), I need to be able to connect to "extenstion@my.dnsalias.com" where the my.dnsalias.com resolves to the Internet IP of my LAN here.

    I tried opening a bunch of ports mentioned in the general settings of 3CX. Doing that doesn't help the lcients I am using (Express Talk from a remote PC, and Fring from a smartphone) cannot connect when using either "extenstion@my.dnsalias.com" or extension@<internetIPaddress>"

    If I put the 3CX computer in the DMZ of my router, then it works, but only with "extension@<internetIPaddress>" However, DMZ's not a real option for anything but testing.

    I saw something in there about a DNS entry to be made, but it points to a blank page in the FAQ. I think what I need is just better info on what ports to open up to get it working without DMZ and then info on the DNS stuff to get it working with the dns address I'm using.

    Thanks.
     
  2. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    Hi Socrates,

    I have tried both Express Talk and x-lite. No need to put any device into DMZ. Just need to do is forward all TCP/UDP ports which from manual.

    Compared both softphone, I recommend to use X-Lite instead of Express Talk .

    The free version is available here:
    http://www.counterpath.com/index.php?menu=Products&smenu=xlite
     
  3. Socrates

    Joined:
    Aug 9, 2007
    Messages:
    4
    Likes Received:
    0
    The ports that I have already opened are: 5060, 9000, 9499, 7000, 7499. They are all set as "virtual server" ports forwarding both UDP and TCP traffic to the IP address of 3CX server.


    Is that the correct setting?
     
  4. SY

    SY Well-Known Member
    3CX Staff

    Joined:
    Jan 26, 2007
    Messages:
    1,821
    Likes Received:
    1
    It is not necessary to open ports that is allocated for local connections.
    It is better to set number of external ports to number equal to expected_number_of_extenral_connections*2. (f.e. 10 connections 20 ports)

    So ports to be opened and forwarded on NAT/Firewall:
    1. SIP ports (5060 by default)
    2. Ports allocated to external connections.

    Please note that not only packets received on ExtAddress:pbx_ext_port must be forwarded to LocalPBXIP:pbx_ext_port. It must work in other direction as well, it means that all packets sent from LocalPBXIP:pbx_ext_port must be forwarded by NAT/Firewall from ExtAddress:pbx_ext_port to WAN.

    Regards,
    Stepan
     
  5. Socrates

    Joined:
    Aug 9, 2007
    Messages:
    4
    Likes Received:
    0
    Thanks guys. I figured it out. Realized it didn't just need 9000 and 9499 it needed 9000 through 9499. Duh.
     
  6. SY

    SY Well-Known Member
    3CX Staff

    Joined:
    Jan 26, 2007
    Messages:
    1,821
    Likes Received:
    1
    Could you please don't forget inform us about success on configuration of your system? :)

    Even if there will be a fault, please inform us as well! We will try to help you.

    Thanks,
    Stepan
     
  7. Socrates

    Joined:
    Aug 9, 2007
    Messages:
    4
    Likes Received:
    0
    I've got it working with the IP address from remote softphones, etc.

    so people can log in as extension@<IP>

    But I still can't make it work with my dynamic DNS domain.

    Anyone know how to do that?
     

Share This Page