Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

How do I disable or change the "My Location - In Office" to be Out of office only?

Discussion in '3CX Phone System - General' started by checkinyyz, Jan 9, 2018.

Thread Status:
Not open for further replies.
  1. checkinyyz

    Joined:
    Dec 17, 2017
    Messages:
    62
    Likes Received:
    1
    Hi everyone. We have 3CX installed on AWS using the PBX Express which gave it an internal IP of 172.31.17.202 on the default VPC since it never let me pick a VPC, and then an elastic IP 35.x.x.x.

    We then have a VPN bonding system that also runs on AWS, completely different VPC but it has an internal IP of 172.31.16.100. Without getting too in depth, we have 2 fibre connections here and LTE, and the VPN bonds them and load balances, sending all traffic out through AWS so if one WAN goes down the others take over and calls aren't dropped.

    When we are in the office, if I set it to send all 3CX traffic over the VPN, our 3CX clients register and show their IP as 172.31.16.100, as expected. The problem is that I guess the client seems to think that 3CX's internal IP of 172.31.17.202 should be accessible internally or something, so there's no audio on calls and they never work. If I go into the account settings in the 3CX client and manually change the "In office" to match our out of office company.3cx FQDN then it works fine, all traffic goes over the VPN and works as expected.

    So long story short, how do I set in office and out of office both to only connect via the FQDN and not the internal IP since the internal IP for 3CX would never be accessible? Manually changing it on the 3CX client works but I'm not sure how long that sticks for, and is kind of confusing to request all my users manually change it.

    Thanks!
     
  2. mariosM_3CX

    mariosM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    406
    Likes Received:
    40
    Hello @checkinyyz

    This can be changed in the extension settings >> Provisioning Tab.
    Just change the "Network interface for registration and provisioning" to your FQDN instead of the local ip and the re-provision the client from the Phones Section.
    Note though that this, depending on your network setup and configuration, may cause some issues as your FQDN will resolve to the public ip of the PBX and firewall may discard requests as bounce back traffic. Of course in your case it may work, as you said that you have already tried it manually, but it's better to try it on a single extension first and make sure that no issues arise.
     
  3. checkinyyz

    Joined:
    Dec 17, 2017
    Messages:
    62
    Likes Received:
    1
    Thanks I'll give that a try now.
     
  4. mariosM_3CX

    mariosM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    406
    Likes Received:
    40
    No problem, hope this helps.
     
Thread Status:
Not open for further replies.