How to disable direct calls to extensions in earlier versions?

Discussion in '3CX Phone System - General' started by lloydr1l, Aug 4, 2016.

Thread Status:
Not open for further replies.
  1. lloydr1l

    Joined:
    Dec 18, 2015
    Messages:
    42
    Likes Received:
    0
    I have a mixture of versions, and I have a request to disable the use of someone calling in and bypassing the Digital Receptionist by entering the extension number. I know in version 14 it can be done under Troubleshooting>Parameters and changing the value for IVR_DIRECT_DIALING_GRAMMAR, but that does not exist in earlier versions (specifically 11), so how would I go about doing this for earlier versions?

    Thanks in advance.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,863
    Likes Received:
    303
    There was (is?) an option in Custom Parameters table called IVRDONOTCALL with a description of...

    "Comma separated list of destination numbers including ranges that will not be allowed for dialing from all IVR in 3CX. Default empty"
     
  3. lloydr1l

    Joined:
    Dec 18, 2015
    Messages:
    42
    Likes Received:
    0
    Thank you leejor. That does look like it might do the trick. I'll try it out tomorrow.
     
  4. lloydr1l

    Joined:
    Dec 18, 2015
    Messages:
    42
    Likes Received:
    0

    This does not appear to work. I entered one extension to test it, restarting the services and re-provisioning the phone as it mentioned in a dialog box, but when selecting the extension, it still rings.

    I saw where this solution was given for someone else in a similar situation, and it did not work for them either, but no posted solution. So I'm wondering what I'm missing for this?
     
  5. lloydr1l

    Joined:
    Dec 18, 2015
    Messages:
    42
    Likes Received:
    0
    So does anyone know why changing the parameter listed below, does not work when given as the solution for stopping direct extension dialing in earlier versions?

    Custom Parameters>IVRDONOTCALL>and changing from blank, to one extension for testing purposes. Call still is going to the extension, and I have restarted services and re-provisioned the phone.

    This is for versions that do not have the other way listed as a solution.
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,863
    Likes Received:
    303
    Could it have anything to do with the SIP ID listed (or not listed) against an extension?
     
  7. lloydr1l

    Joined:
    Dec 18, 2015
    Messages:
    42
    Likes Received:
    0
    Sorry leejor, I'm not understanding what you are saying.
     
  8. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,863
    Likes Received:
    303
    I may be grasping at straws as I'm not clear on why the options isn't working for you.

    In each extensions settings, you can put in a SIP ID, which could be different (or the same) as the extension number. If you have put in the same number, rather than leaving it blank, it could make a difference.
     
  9. lloydr1l

    Joined:
    Dec 18, 2015
    Messages:
    42
    Likes Received:
    0
    Got it. The field is blank, as I have never filled it in. I guess this is something that just does not work. I have now tried it on another system, same older version, and it too does not work. Calls still go to the extension. So between neither of these working, and having read on another post that theirs did not work, I can only conclude this does not work for stopping calls to an extension.
     
  10. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,863
    Likes Received:
    303
  11. lloydr1l

    Joined:
    Dec 18, 2015
    Messages:
    42
    Likes Received:
    0
    :) That's the other post I was referring to. Nick is talking about how it's handled in V14, whereas I am dealing with an earlier version in this case. The IVR_DIRECT_DIALING_GRAMMAR value does not exist in the earlier version, and the IVRDONOTCALL value is not working for some reason.

    The post by lejeje states he wasn't able to get it to work either, although for a different version.
     
  12. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,367
    Likes Received:
    83
    I am not sure if this will work on V11, quite frankly I haven't got one available where I can test it on, but try creating the IVR_DIRECT_DIALING_GRAMMAR parameter and setting the value you want. In regard to the IVRDONOTCALL, I am not sure.
     
Thread Status:
Not open for further replies.