How to force SIP(make call) mode instead of CTI

Discussion in '3CX Phone System - General' started by chrischevy, Nov 20, 2014.

Thread Status:
Not open for further replies.
  1. chrischevy

    Joined:
    Jun 7, 2010
    Messages:
    74
    Likes Received:
    0
    We're having some issues with CTI mode on Yealink phones
    See: http://forum.yealink.com/forum/showthread.php?tid=2430&highlight=auto+answer

    I know that we're supposed to use CTI mode in "single line" mode, but this is not an option for us (or our customers)
    Is there a way to disable CTI mode and simply use the SIP (or make call) mode (I'm not sure is this is how it's called) ? I can't find a way to do this.

    Thank you
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. pj3cx

    pj3cx Active Member

    Joined:
    Aug 1, 2013
    Messages:
    646
    Likes Received:
    1
    Re: How to force SIP mode instead of CTI

    Hi there,
    I'm afraid you can't disable the mode or rather the ability of user to switch between modes, but you can set the default mode (by default CTi) from the 3CX Phone System / extension properties / 3CXPhone tab / tick "Configure default phone to use in 3CXPhone for Windows", switch dropdown to "Inbuild Softphone". Apply.
    Reprovision 3CXPhones (restarting them will trigger provisioning).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. chrischevy

    Joined:
    Jun 7, 2010
    Messages:
    74
    Likes Received:
    0
    Re: How to force SIP mode instead of CTI

    I'm not sure if I explained my question correctly: I would like the Yealink phones to work like a phone that is not compatible with CTI (like Cisco or Aastra)

    On our Cisco and Aastra phones, we see "makecall" on the lcd when calling from 3CX Phone. This is the mode I would like to use on the Yealink. The problem with CTI is that, if there is a current call and a second call comes in, the phone answers the second call automatically when the first call is ended, even if it's the remote person who hangs up first. It creates a lot of confusion when you finish a conversation a another call comes up on the speaker phone...

    Like I said in my previous post, using only one line is not an option for us or our customers.

    Does anyone know if the same issue exists with the Snom phones ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Gabriele

    Joined:
    Oct 12, 2011
    Messages:
    13
    Likes Received:
    0
    I confirm the issue and we have asked the same "make call" to 3CX support, but they say that it isn't possible..
     
Thread Status:
Not open for further replies.