Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

How to refresh Extension Status?

Discussion in '3CX Phone System - General' started by kargo1977, Jan 20, 2010.

Thread Status:
Not open for further replies.
  1. kargo1977

    Joined:
    Dec 16, 2009
    Messages:
    16
    Likes Received:
    0
    Often i get some strange things in the extension status on 3cx management console.
    Some extensions which were in use with the mobile sip clients are still presented online, even after they are disconnected long time ago.
    This also happened when I registered and made calls with 3cx voip phone that is outside the lan in which 3cx voip system resides, even after I took good care of the way how I disconnected (right click and Exit).

    Is there a solution to refresh the status of extensions in management console from time to time???
     
  2. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,526
    Likes Received:
    71
    You don't have to refresh them - extensions will become "red" after their registration timeout will expire.

    As an explanation: it's an annoying but normal behavior in the case when devices don't - or cannot - unregister themselves properly. A quite good example of "cannot" is following: you have a hardphone registered (for 30 mins), to PBX. After 5 mins, you turn its power off - on the PBX, its extension will remain as registered for still 25 mins. In case of softphones, such behavior may happen when they crashes, are killed, or their computer are crashing, rebooted and so on, or when network condition changes.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. kargo1977

    Joined:
    Dec 16, 2009
    Messages:
    16
    Likes Received:
    0
    Ok, now it's been a whole week since i have registered some extensions, done my calls and unregistered them correctly, but i still have them as online in management console.
    Another thing! Last night, at home, i registered an extension over TCP tunnel on port 5090, and had 1 phone call through pstn gateway Linksys SPA3102, which is on the same LAN as 3CX server at work and unregistered it correctly - right click and exit, after the phone call. Call was correctly set but there was some significant delay (almost 5 seconds delay! I blame slow internet speed at home). I am using tunnel because both computers (at home and at work) are behind NAT, so I have double NAT situation.
    This morning at work i checked Server Activity Log and saw that that call ended exactly 3 hours after I finished and unregistered. During that time SPA3102 was unavailable for other users, saying "There are no available outbound lines on gateway spa3102 at this time".
    So my question is, since I am using TCP to establish a call and TCP is more demanding protocol in way that every packet must get to its destination, if I have a slow internet speed (upload speed is under 100kbps) some packets will travel slowly to its destination and maybe get lost, so does it affect communication through tunnel in way that it remains open and wait for ALL TCP packets to arrive?
    Oh, just to mention that this extension still appears in green/online!!!
     
Thread Status:
Not open for further replies.