Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

How to set up QoS on Linksys WAG325N

Discussion in '3CX Phone System - General' started by regfixit, Sep 26, 2008.

Thread Status:
Not open for further replies.
  1. regfixit

    Joined:
    Mar 7, 2008
    Messages:
    35
    Likes Received:
    0
    I've just changed my router to Linksys 325N that supports QoS and am wondering how to set up QoS to prioritise my VOIP.
    Am I right in thinking I should define a new application, port range 9000-9015 UDP (outbound ports) and set the priority to high ?
    Do I also need to add the SIP port 5060 ?

    Or am I off the mark altogether with this ?

    My set up is 3CX server running on PC behind the WAG325N; linksys spa3102 to provide PSTN gateway; thomson ST780 to provide 2 FXS extensions.

    Thanks for any advice.
     
  2. regfixit

    Joined:
    Mar 7, 2008
    Messages:
    35
    Likes Received:
    0
    I have partly answered my question because I set it up like this:
    9000-9015 UDP, 5060 TCP -> priority high

    the received audio started to break up. I changed the port range to
    9000-65534 UDP, 5060 TCP -> priority high

    and it was OK. It seems therefore that the RTP port range is extending beyond that in the 3cx config ?
     
  3. monzer_yazigi

    Joined:
    Sep 27, 2008
    Messages:
    1
    Likes Received:
    0
    Hi,
    I am facing in configuring my Linksys WAG325N to run VoIP (SIP) over it.

    Can you advise, the configuration you followed in order to make it work?

    Many thanks
     
  4. regfixit

    Joined:
    Mar 7, 2008
    Messages:
    35
    Likes Received:
    0
    I assume you are running 3cx on a PC behind the WAG325N and have already set it up to connect to your ISP via the ADSL connection.

    First thing I had to do was assign the PC on which I am running 3cx a static IP address (my previous Netgear router had feature callled DHCP address reservation where you could use DHCP but ensure that a given device always received the same IP address, but the Linksys doesn't have this). By default the Linksys has DHCP assigned starting from address 192.168.1.100 so for example give your PC static IP address 192.168.1.10.

    Then you have to set up the WAG325N to forward the correct ports to your static IP address PC.

    Log in to router admin page and go to the tab "Applications and gaming", then click on "port range forwarding" and create the following entries:
    applicaiton start end protocol IP address Enable
    SIP 5060 5060 Both 192.168.1.10 X
    RTP 9000 9015 Both 192.168.1.10 X
    STUN 3478 3478 Both 192.168.1.10 X

    In your 3cx General settings I am assuming you have "Ports to use for external calls" = 9000 - 9015 and STUN server options set up to use 3478.

    I think probably in the above firewall settings you could have the SIP protocol as TCP only and the RTP as UDP but setting to both covers all bases.

    Make sure you are not also running Windows Firewall or any other 3rd party firewall on your PC, or if you are that you open the same ports as above.
     
Thread Status:
Not open for further replies.