I can't make calls to/from ascom wireless voip phones

Discussion in '3CX Phone System - General' started by charlie00tj, Sep 13, 2008.

Thread Status:
Not open for further replies.
  1. charlie00tj

    Joined:
    Sep 13, 2008
    Messages:
    1
    Likes Received:
    0
    17:11:36.851 Call::Terminate [CM503008]: Call(25): Call is terminated
    17:11:36.851 CallCtrl::eek:nIncomingCall [CM502001]: Source info: From: 25; To: "1000"[sip:1000@1000;user=phone];tag=3309022037[sip:1002@1000;user=phone]
    17:11:36.851 CallCtrl::eek:nIncomingCall [CM503013]: Call(25): Incoming call rejected, caller is unknown; msg=SipReq: INVITE 1002@1000 tid=-65A184A9 cseq=INVITE contact=1000@10.199.1.105:5060 / 11 from(wire)
    17:11:35.960 evt::CheckIfAuthIsRequired::not_handled [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:1002@1000 SIP/2.0
    Via: SIP/2.0/UDP 10.199.1.105:5060;branch=z9hG4bK-65A184A8
    Max-Forwards: 70
    Contact: [sip:1000@10.199.1.105:5060;user=phone]
    To: [sip:1002@1000;user=phone]
    From: "1000"[sip:1000@1000;user=phone];tag=3309022037
    Call-ID: e141a750e909d311998e00013e102334@10.199.1.105
    CSeq: 10 INVITE
    Allow: REGISTER, SUBSCRIBE, NOTIFY, INVITE, ACK, OPTIONS, BYE, CANCEL, REFER, INFO, UPDATE
    Supported: replaces, sec-agree, answermode
    User-Agent: (Ascom i75/6.00 Ascom 1.4.21 \(2007-10-19\) release [XX-XXXX])
    P-Preferred-Identity: "1000" [sip:1000@10.199.1.105:5060;user=phone]
    Content-Length: 0
    Remote-Party-ID: "1000" [sip:1000@10.199.1.105:5060;user=phone];party=calling;screen=no;privacy=off
     
  2. austinjw

    Joined:
    Mar 19, 2009
    Messages:
    2
    Likes Received:
    0
    I'm having the same problem. Did you ever get your problem resolved??

    Jim Austin
    Houston, TX
     
  3. William400

    William400 Well-Known Member

    Joined:
    Aug 21, 2006
    Messages:
    1,005
    Likes Received:
    0
    Hi

    Are you sure that the Ascom is actually register to 3CX? The FROM field in the INVITE shows 1000@1000 when it should be 1000@IP of PBX.

    Please check your Ascom config. Please advise the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. moon1234

    Joined:
    Jan 25, 2008
    Messages:
    24
    Likes Received:
    0
    This seems to be happening to a LOT of devices in version 7. The problem appears to stem from how the phone presents itself to 3CX when a call is in progress. Take this example:

    Phone extension: 1452

    Phone sends 1452@216.216.216.216 as it's ID string to 3cx instead of 1452@sip.mycompany.com

    Local SIP domain is set to sip.mycompany.com on 3cx. All calls fail when placed from a device that sends its public IP after its extension (i.e. 1452@216.216.216.216). 3cx reports the caller is not authorised and instructs the admin to check the invite information for errors. If the phone can send 1452@sip.mycompany.com then the RTP setup proceeds. The phone cal always login via SIP and see status and send/receive control information. All call setup fails though unless the phone sends the local sip domain. Changing the local SIP domain to the local IP on the NIC on the server or the public IP of the nic on the server does not resolve the problem for devices located on the public internet.

    This is a new bug in version 7 as it does not happen in version 6. All of my utstarcom F3000 wifi phones have stopped working. They are unable to send their extension followed by the SIP domain. The F3000 sends its extension followed by it's STUN derived IP address. Version 7 of 3cx does not loike this and refuses RTP setup even though the phone is properly registered via SIP.

    Many other people who have older devices are having this same problem. Several people with WiFi phones and many with NON 3cx approved ATA's.

    3cx needs to address this oversight so that we don't have to toss our old equipment.
     
  5. moon1234

    Joined:
    Jan 25, 2008
    Messages:
    24
    Likes Received:
    0
    I was wondering if anyone has come up with a way to disable the local SIP domain checking "feature" in 3cx. I would prefer to not rollback to version 6 if possible.

    Thanks.
     
Thread Status:
Not open for further replies.