IIS 7 error

Discussion in '3CX Phone System - General' started by jmatson, Nov 30, 2009.

Thread Status:
Not open for further replies.
  1. jmatson

    jmatson New Member

    Joined:
    Nov 30, 2009
    Messages:
    122
    Likes Received:
    0
    when i try to open the IVR webpage. This is a freash install of 3CX i get a error msg

    http://XXXXXXXXX:5484

    Edited by Moderator
     
  2. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,399
    Likes Received:
    79
    It seems that your WebServer service is not Started.

    Go to Start > Run > Services.msc
    Find the 3CX WebServer right Click and press Start Service.

    That should do the trick.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. jmatson

    jmatson New Member

    Joined:
    Nov 30, 2009
    Messages:
    122
    Likes Received:
    0
    it doesn't list a webserver.
     
  4. jmatson

    jmatson New Member

    Joined:
    Nov 30, 2009
    Messages:
    122
    Likes Received:
    0
    Code:
      <?xml version="1.0" encoding="utf-8" ?> 
    - <vxml version="2.0" application="root.vxml">
    - <!--  Parametrized variables 
      --> 
      <var name="from" expr="'unk'" /> 
      <var name="to" expr="'unk'" /> 
      <var name="menu" expr="'unk'" /> 
      <var name="isid" expr="''" /> 
    - <!--  Calcualted vars 
      --> 
      <var name="ivr_menu_type" expr="'invalid'" /> 
      <var name="from_type" expr="'line'" /> 
      <var name="ext_len" expr="3" /> 
      <var name="ec_prompt" expr="'EMPTY'" /> 
      <var name="dr_link" expr="'dr.aspx'" /> 
    - <!--  Insert here 
      --> 
      <var name="ext_pin" expr="''" /> 
    - <form id="main">
    - <block>
      <goto expritem="ivr_menu_type" /> 
      </block>
    - <block name="invalid">
      <audio src="GetPrompt.aspx?id=NOACTPERF" /> 
      <disconnect /> 
      </block>
    - <block name="end_call">
      <audio expr="'GetPrompt.aspx?id='+ec_prompt" /> 
      <disconnect /> 
      </block>
    - <subdialog name="vmail_menu" srcexpr="'LoginVmail.vxml'">
      <param name="vmbox" expr="from" /> 
      <param name="vmpin" expr="ext_pin" /> 
      <param name="ext_playcid" expr="ext_playcid" /> 
      <param name="ext_playdt" expr="ext_playdt" /> 
    - <filled>
      <disconnect /> 
      </filled>
      </subdialog>
    - <subdialog name="queue_menu" srcexpr="'QueueMenu.aspx?qdn='+to">
    - <filled>
      <disconnect /> 
      </filled>
      </subdialog>
    - <subdialog name="dr_menu" srcexpr="dr_link+'?dr='+menu+'&to='+to+'&from='+from">
    - <filled>
      <disconnect /> 
      </filled>
      </subdialog>
    - <subdialog name="rec_menu" srcexpr="'RecVmail.vxml'">
      <param name="extension" expr="to" /> 
      <param name="caller" expr="from" /> 
    - <filled>
      <disconnect /> 
      </filled>
      </subdialog>
    - <subdialog name="make_call" srcexpr="'MakeCall.vxml'">
      <param name="to" expr="to" /> 
    - <filled>
      <disconnect /> 
      </filled>
      </subdialog>
    - <subdialog name="boom_caller" srcexpr="'BoomCaller.aspx?to='+to+'&from='+from">
    - <!-- 'BoomCaller.vxml'"
      --> 
      <param name="to" expr="to" /> 
    - <filled>
      <disconnect /> 
      </filled>
      </subdialog>
    - <subdialog name="boom_acceptor" srcexpr="'BoomAcceptor.aspx'">
      <param name="from" expr="from" /> 
      <param name="to" expr="to" /> 
    - <filled>
      <disconnect /> 
      </filled>
      </subdialog>
      </form>
      </vxml>
     
  5. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,399
    Likes Received:
    79
    Oh sorry, i totally missed the Title of the Post :p

    Try the following:

    Go to Start > Run > Services.msc
    Find the 3CX Configuration Server and Restart it.

    Then Restart IISAdmin through the Services.msc as well


    If the above doesnt work, try installing the K-Lite Codec Pack.
    Get it here: http://www.free-codecs.com/download/K_lite_codec_pack.htm

    And see what happens.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. jmatson

    jmatson New Member

    Joined:
    Nov 30, 2009
    Messages:
    122
    Likes Received:
    0
    didn't work.
     
  7. jmatson

    jmatson New Member

    Joined:
    Nov 30, 2009
    Messages:
    122
    Likes Received:
    0
    i'm using IIS7 not the built in web server
     
  8. jmatson

    jmatson New Member

    Joined:
    Nov 30, 2009
    Messages:
    122
    Likes Received:
    0
    i reinstalled and a different server using the built in web server and i get the same problem
     
  9. MichaelB

    MichaelB Member
    3CX Support

    Joined:
    Aug 25, 2009
    Messages:
    401
    Likes Received:
    3
    Hi Jmatson,
    If this is a web server do the following:

    Go to Control Panel and click on “Programs and Features”. Click on “Turn Windows Features On or Off”. The Windows Server Manager Display will show.

    Click on Roles and proceed to add a new role. The Add Roles Wizard will appear. Under Select Server Roles, tick on the Web Server (IIS).

    When installation is finished, go to Start > Run and open IIS Manager (inetmgr).

    Some changes must be done to the IIS Manager IVR. Select IVR and open Compression. Enable static content compression must be disabled.

    Open MIME Types and check that .vxml is added. If not, add one by pressing Add in the Actions Bar.
    File name extension : .vxml
    Mime Type: text/plain

    You will need to restart the machine.

    Tell me how it goes.
    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. jmatson

    jmatson New Member

    Joined:
    Nov 30, 2009
    Messages:
    122
    Likes Received:
    0
    that didn't work.
    i also have the same problem with the webserver that 3CX installs.
     
  11. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,399
    Likes Received:
    79
    For the Webserver what you can do is download the new Cassini WebServer from here:
    http://ultidev.com/download/CassiniDownload.aspx

    Select the 2005 Package and install it.
    After a service restart this might fix your problem with the Inbuilt Webserver.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. cfive

    cfive Member

    Joined:
    Aug 20, 2009
    Messages:
    284
    Likes Received:
    3
    Does this (old) post contain the entire IIS7 configuration required (WS 2008 R2)?. I have seen references to more configurations, here and there, but nothing all in one place. There is a more complete list posted, but the links to MS KB articles are all out-dated, for IIS6.

    Is there an IIS7 configuration requirement list, somewhere?

     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.