IIS7 and 3CX Ports

Discussion in '3CX Phone System - General' started by Ase, Jan 15, 2009.

Thread Status:
Not open for further replies.
  1. Ase

    Ase

    Joined:
    Jan 12, 2009
    Messages:
    58
    Likes Received:
    0
    Hi,

    This is more an IIS7 question than 3CX but I hope I can get some help from you.
    Here is my setup:
    Windows 2008 + IIS7 + Exchange 2007 with OWA.
    Exchange OWA is setup in "Default WEB Site" and only allowing SSL, also port 443 is forwarded thrue the firewall to the server.
    Now I installed 3CX and that also installed into "Default WEB Site".
    My problem with this is that I now can connect to 3CX Management console from the outside because the firewall forwards the SSL trafic and that is not what I want.

    Can I configure 3CX to only allow http port 80 (port 80 is not forwarded thrue the firewall), I think SSL is always possible?
    Can I change the port that 3CX uses for the console?
    Other sollutions?

    //Ase
     
  2. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Hi Ase

    What i think you are asking is if there is a way to prevent people from getting to the 3CX management pages from the internet?

    You may be able to restrict access by using the "IP address and name restrictions" option in the properties of the "Management" virtual folder from within IIS manager. Change the option from "All granted access" to "Denied access" and add an exception for the internal network IP's or subnet.

    I have not tested this but it should be fairly easy for you to test. Let us know if it works for you.

    John
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Ase

    Ase

    Joined:
    Jan 12, 2009
    Messages:
    58
    Likes Received:
    0
    Hi John,

    You are spot on, exactly what I want to do.
    But I cannot find the setting in IIS7, can you guide me?
    IIS6 seemed a lot easier to manage than this new one. There is a lot of settings that I cannot find anymore.

    //Ase
     
  4. islander

    Joined:
    Jan 15, 2009
    Messages:
    7
    Likes Received:
    0
    I'm running SBS 2008, I have don't have the OWA in the defeault website it is in another called "SBS web apps" and the difference's that i can see is the "Site bindings" (right click edit bindings) the default is only bound to port 80 and the SBS web app site to port 443 if i try https://myhost/management i will get a 404 error...
     
  5. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Hi Ase

    With IIS7 Microsoft in their wisdom did not enable by default the IpRestrictionModule feature.
    To enable it run the following commands from a command prompt

    ServerManagerCmd –install Web-IP-Security

    iisreset


    After that open up the IIS Manager and you will find a new icon "IPv4 Address and Domain Restrictions" in the IIS properties of each of the Virtual Directories.

    John
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    So what is the question?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Ase

    Ase

    Joined:
    Jan 12, 2009
    Messages:
    58
    Likes Received:
    0
    Hi John,

    Thanks a lot for your help, the solution works perfectly.

    //Ase
     
Thread Status:
Not open for further replies.