Solved Inbound After hours routing not working

Discussion in '3CX Phone System - General' started by AndrewT, Jan 12, 2018.

Thread Status:
Not open for further replies.
  1. AndrewT

    Joined:
    Oct 7, 2015
    Messages:
    13
    Likes Received:
    1
    We have setup the inbound rules for a number of our lines to go to a voicemail extension outside of office hours. This was working up to a few weeks ago (maybe it broke longer ago, but we didn't notice it), but now it seems to be ignoring the office hours completely and tries to route calls into our call Queues.

    I have both inbound rules setup for the outside of office hours as well the same setting in one of the SIP trunk setups. The setup isn't very complicated, so I am not sure what to try next. And it was working under V14 and the only thing that changed was the updates (we are currently running V15.5.6354.2).

    Anyone else have this problem? Any ideas on what to try next?
     
  2. kieferschild

    Joined:
    Jul 1, 2016
    Messages:
    71
    Likes Received:
    7
    How are you specifying office hours? globally or per SIP trunk/inbound rule?

    Check the time on your 3CX server.

    the inbound rule will match that of the DID from your SIP Trunk.
     
  3. AndrewT

    Joined:
    Oct 7, 2015
    Messages:
    13
    Likes Received:
    1
    I am using global office hours.

    The time stamps on the call logs are all correct, so with that I am assuming that the 3CX server clock is correct.

    I had setup inbound rules in V14 that are still in place, but I noticed the other day that V15 had added out of office hour settings for the SIP trunks as well. I thought this was the problem, but adding a rule there as well didn't make any difference.
     
  4. datamerge

    datamerge New Member

    Joined:
    Nov 19, 2014
    Messages:
    169
    Likes Received:
    19
    I've seen this before. Are you using cloud? It actually happened on our own system. You will probably find that it is working, but the out of hours are running at UTC time. I assume you are on Linux? Log in to the Linux command prompt as root. Run the following command.
    dpkg-reconfigure tzdata
    Choose your appropriate country/city. This should fix it if it is the above problem.
     
    accentlogic likes this.
  5. AndrewT

    Joined:
    Oct 7, 2015
    Messages:
    13
    Likes Received:
    1
    We are not using a cloud or Linux. Simple windows based onsite server.

    I tried deleting the hour settings and re-entering them, but no effect.

    The setup displays the correct time zone.

    Still baffled.
     
  6. eddv123

    eddv123 Well-Known Member

    Joined:
    Aug 15, 2017
    Messages:
    1,006
    Likes Received:
    153
    You could check the server time is correct but this would be doubtful if it was working previously. Unless you have moved machines/VM's etc.

    Another common issue that occurs sometimes is when/if people have the Force PBX * code in place.

    It is described as FORCE in/out of office hours. By this it means it would be a global override so must be treated separately to the standard hours.

    This dial code is a code that when used, will set the entire PBX to either:

    * In office hours
    * Out of Office hours
    * Back to auto switching based on time (global PBX hours).

    For example *64 (with nothing appended), means a prompt will be played stating that “3CX is now using the DEFAULT OFFICE HOURS”. This means that the PBX will override the previous FORCE commands and go back to the standard PBX hours.

    It could be a possibility someone has set this and not resorted back using *64. Worth checking.https://www.3cx.com/docs/pbx-dial-codes/
     
    datamerge and accentlogic like this.
  7. AndrewT

    Joined:
    Oct 7, 2015
    Messages:
    13
    Likes Received:
    1
    Yep, that was it. I forgot that I had tried to do something quick for a mid-day office holiday party.

    I knew it had to be something simple.

    Thanks all.
     
Thread Status:
Not open for further replies.