Inbound call routes to default IP 169.254.153.x

Discussion in '3CX Phone System - General' started by qmondo, Oct 28, 2009.

Thread Status:
Not open for further replies.
  1. qmondo

    Joined:
    Oct 28, 2009
    Messages:
    2
    Likes Received:
    0
    I have been struggling with this for a number of nights now!

    All internal calls (ext to ext) work fine picking up the registered STUN address (101@xxx.xxx.xxx.xxx:port), but as soon as a call comes in from the SIP trunk it looks for 101@169.254.153.22:5060. The trunk has been configured to send to ext 101, but it does not pick up the correct IP for the ext.

    The OS is Vista Home Premium, but in theory it should work.

    Has anyone encountered this before?
     
  2. nml

    nml

    Joined:
    Oct 8, 2009
    Messages:
    21
    Likes Received:
    0
    does your 3cx server have a couple different network cards or tunnel adapters? 169.254.x.x is the automatic private ip addressing (APIPA) range that most systems default to when it can't find a DHCP server.
     
  3. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,400
    Likes Received:
    79


    Try Putting your External IP Manually in the Settings > Network Settings > Stun Section so it doesnt use STUN
    In Settings > Advanced > Local Sip Domain put the IP of your Ethernet adapter.
    And make sure your ethernet adapter doesnt have an IP of the 169.254.xxx.xxx sort or else most likely nothing will work.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. qmondo

    Joined:
    Oct 28, 2009
    Messages:
    2
    Likes Received:
    0
    Thanks for the support guys.

    It was the Local SIP Domain setting in Settings > Advanced that was still set to "3cx.local". As soon as I set this to the local IP of the server "192.168.x.x" the calls came flooding in. The server was looking for "3cx.com" which didn't exist so therefore assigning a APIPA to resolve an internal address.

    Thanks again for the push in the right direction.
     
Thread Status:
Not open for further replies.