Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Inbound Caller ID missing Country Code

Discussion in 'Windows' started by chelsea_d_w, Sep 2, 2015.

Thread Status:
Not open for further replies.
  1. chelsea_d_w

    Joined:
    Sep 2, 2015
    Messages:
    1
    Likes Received:
    0
    (In Canada)
    All inbound calls are showing as 10 digits, as opposed to 11 including the '1' prefix for Canada/US numbers. How can I make this show up, so that when scrolling through call history, for long distance callers, I can just hit ok and it will dial. Currently it will not allow this, so I have to remember the phone number, and manually enter, including the 1 at the beginning.

    ie. Long distance caller (555)555-5555 shows up. Want it to show as 1(555) 555-5555 to enable easy dial from call history.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,093
    Likes Received:
    327
    Ate you complaining that your provider isn't sending the country code (or long distance access code if you are in Canada) or asking how to prefix, or a work-around in 3CX?

    Normally, because 3CX doesn't actually know what country code to prefix, you have to create outbound rules that will add any required prefix digits. So...if you dial 555 555 5555 you will have to have a rule that is ( probably) based on the number of digits, recognises that the call is national, will prefix the digit 1 (LD access code, not country code). Overseas calls, given the various digit lengths, are too difficult to prefix automatically.
     
Thread Status:
Not open for further replies.