Inbound Calls Hang up

Discussion in '3CX Phone System - General' started by pmoutzouris, Mar 19, 2012.

Thread Status:
Not open for further replies.
  1. pmoutzouris

    Joined:
    Mar 9, 2012
    Messages:
    4
    Likes Received:
    0
    Hi,

    We are trialing the 3CX system. We currently are able to make outbound calls.
    However we are unable to make inbound calls. When calling in the call hangs up before it is answered.

    The strange thing is, incoming calls appeared to work a few days ago for a short while. I suspect it was intermittent.

    We have tried to resolve the issue with our VOIP provider without success. Can you help?

    The error log is as follows:

    10:22:09.050 [CM102001]: Authentication failed for SipReq: INVITE XXXXX915@203.206.220.195:5062 tid=03ebc2b1 cseq=INVITE contact=XXXXX678@202.43.66.5 / 103 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    INVITE sip:XXXXX915@203.206.220.195:5062 SIP/2.0
    Max-Forwards: 70
    To: <sip:XXXXX915@203.206.220.195:5062>
    Call-ID: 26cf63ac014bd1386c6680d8708e6ce2@202.43.66.5
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO
    Proxy-Authorization: Digest username="09533678",realm="3CXPhoneSystem",algorithm=MD5,uri="sip:XXXXX915@203.206.220.195:5062",nonce="414d535c0576ff2001:b4d26dc38ee2bc6f81e0690f106b64e3",response="dd8aea76717fe7b0182f7e22b0f671c2"
    User-Agent: Asterisk PBX 1.6.2.20
    Remote-Party-ID: "0410501876" <sip:XXXXX876@202.43.66.5>;privacy=off;screen=no
    10:22:09.050 [CM302002]: Authentication failed due to unidentified source of: SipReq: INVITE 0281881915@203.206.220.195:5062 tid=03ebc2b1 cseq=INVITE contact=XXXXX678@202.43.66.5 / 103 from(wire)
    INVITE sip:XXXXX1915@203.206.220.195:5062 SIP/2.0
    Max-Forwards: 70
    To: <sip:0281881915@203.206.220.195:5062>
    Call-ID: 26cf63ac014bd1386c6680d8708e6ce2@202.43.66.5
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO
    Supported: replaces, timer
    Content-Length: 0

    10:21:47.487 Currently active calls [none]
    10:21:44.378 [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    Via: SIP/2.0/UDP 202.43.66.5:5060;branch=z9hG4bK739983d0;rport=5060
    Contact: <sip:XXXXX678@202.43.66.5>

    Many thanks in advance....

    Kind Regards
    Paul
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,781
    Likes Received:
    287
    Is the IP, that they are sending call to you from, included in the 3CX data-fill, for their trunk group, or do you just have their domain name?
     
  3. pmoutzouris

    Joined:
    Mar 9, 2012
    Messages:
    4
    Likes Received:
    0
    Hi,

    We were using the domain name for the SIP server hostname. However after getting your post we also tried using the IP address. There was no improvement.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,781
    Likes Received:
    287
    Here is a link to some information on the problem you seem to be having. The last line (port number), could be the problem.
    http://www.3cx.com/blog/docs/source-identification-issues/
     
  5. pmoutzouris

    Joined:
    Mar 9, 2012
    Messages:
    4
    Likes Received:
    0
    Ok. We just fixed the issue.

    It turns out that for connection to our VOIP provider (Faktortel) on inbound parameters the following setting is required:

    Requested Line URI:Hosy Pat "ContactUro", usually, content of Contact field.

    We are now receiving call. I am not exactly sure why the above has worked. It was more trial and error than brains.

    Thanks for the help.
     
  6. pmoutzouris

    Joined:
    Mar 9, 2012
    Messages:
    4
    Likes Received:
    0
    Hi,

    I spoke too soon. Inbound calls worked for a about 5 times. Now its back to being busy.

    It seems our inbound calls are intermittent.

    Not sure what is going on...

    Kind Regards,
    Paul
     
Thread Status:
Not open for further replies.