Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Solved inbound calls not connecting - 404

Discussion in '3CX Phone System - General' started by Bret Gordon, Jun 16, 2017.

Thread Status:
Not open for further replies.
  1. Bret Gordon

    Joined:
    Jun 16, 2017
    Messages:
    24
    Likes Received:
    3
    Hi, I can't figure out why inbound calls aren't connecting. I have set up a trunk with Flowroute with a DID, set it up in 3CX with the template, configured outgoing route and incoming route (to IVR ext.), and several extensions.

    Inter-office and outgoing calls work fine.

    Event log shows:

    Call or Registration to 1405XXXXXXX@(Ln.10000@Flowroute) has failed. 216.115.69.144 replied: 404 Not Found; from IP:216.115.69.144:5060

    What does this mean???
     
  2. Bret Gordon

    Joined:
    Jun 16, 2017
    Messages:
    24
    Likes Received:
    3
    Why does Flowroute send a 404? As I mentioned, it is registered and outgoing calls work perfectly. Surely someone knows what this indicates. While I'm new to 3CX, I have 35+ years experience and 20 in Linux. Just trying to understand how I may have configured 3CX wrong. TIA
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,086
    Likes Received:
    325
    That log would indicate that the particular call did not go through, that the number you send was not found. If calls do seem to be working, then I would contact the provider for an explanation.

    What does a log look like for an incoming call? Is there one? If not, then perhaps it is your registration information that is incorrect.
     
  4. Bret Gordon

    Joined:
    Jun 16, 2017
    Messages:
    24
    Likes Received:
    3
    Thank you. I'll contact Flowroute tech support. I've been unable to receive any incoming calls at all, so no logs other than what I posted. :(
     
  5. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,341
    Likes Received:
    535
    Hello @Bret Gordon

    Please try navigating to the trunk Inbound parameters and enable the option "Look for the DID number in these fields".
    Then configure it like the screen shot below

    2017-06-19_10h45_50.png
    Let us know if that worked.
     
    SomeInactive and Mike Chadwick like this.
  6. Bret Gordon

    Joined:
    Jun 16, 2017
    Messages:
    24
    Likes Received:
    3
    That did the trick. Thank you!
     
  7. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,341
    Likes Received:
    535
    Glad to hear the issue is resolved :)
     
Thread Status:
Not open for further replies.