Inbound calls with SIP trunk from IPAustria

Discussion in '3CX Phone System - General' started by mburtscher, Oct 6, 2017.

Thread Status:
Not open for further replies.
  1. mburtscher

    Joined:
    Oct 6, 2017
    Messages:
    11
    Likes Received:
    1
    Hello,

    I'd like to configure 3CX with our existing SIP trunk from IPAustria. I already managed to add the trunk (using “generic”) and get outbound calls working. But inbound calls always show errors in the logs:

    Trunk settings

    Registrar:
    node5.ipaustria.at:5060
    Outbond proxy: -
    Authentication: Register/Account based
    Authentication ID: [ID]
    Authentication Password: [PW]
    3 Way Authentication: No

    Main Trunk No: 0043552321***
    DIDs: 00435523213** / 00435523213**10 / 00435523213**11

    PBX Delivers Audio: Yes
    Supports Re-Invite: No
    Supports Replaces: No
    Public Public IP in SIP VIA Header: No
    SRTP: No

    "CallerNum" caller's number: From: Display Name
    "CalledNum" number that has been dialed: To: Display Name
    "CallerName" caller's name: From: User Part

    Call Source Identification: No

    Log in “Verbose” mode

    Code:
    10/05/2017 5:47:14 PM - [CM302002]: Authentication failed due to unidentified source of: SipReq:  INVITE 0@52.57.244.62:5060 tid=5404da7f cseq=103 INVITE contact=004366444959**@213.208.5.40 / 103 from(wire)
    10/05/2017 5:47:14 PM - [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    Invite-UNK Recv Req INVITE from 213.208.5.40:5060 tid=595e2bcb Call-ID=0eb42964402a4cec1d751b9418955ead@213.208.5.40:
    INVITE sip:0@52.57.244.62:5060 SIP/2.0
    Via: SIP/2.0/UDP 213.208.5.40:5060;branch=z9hG4bK595e2bcb;rport=5060
    Max-Forwards: 70
    Contact: <sip:004366444959**@213.208.5.40>
    To: <sip:0@52.57.244.62:5060>
    From: "004366444959**" <sip:004366444959**@213.208.5.40>;tag=as35330886
    Call-ID: 0eb42964402a4cec1d751b9418955ead@213.208.5.40
    CSeq: 102 INVITE
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO
    Content-Type: application/sdp
    Date: Thu, 05 Oct 2017 15:47:14 GMT
    Supported: replaces
    User-Agent: Voicenode Providersystem v 3.5.1
    Content-Length: 338
    
    v=0
    o=root 11690 11690 IN IP4 213.208.5.40
    s=session
    c=IN IP4 213.208.5.40
    t=0 0
    m=audio 12078 RTP/AVP 8 111 18 3 0 101
    a=rtpmap:8 PCMA/8000
    a=rtpmap:111 G726-32/8000
    a=rtpmap:18 G729/8000
    a=fmtp:18 annexb=no
    a=rtpmap:3 GSM/8000
    a=rtpmap:0 PCMU/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16
    a=ptime:20
    a=sendrecv
    10/05/2017 5:47:14 PM - IPs do not match!
    10/05/2017 5:47:14 PM - Compare IPs: incoming=213.208.5.40; external=0.0.0.0
    10/05/2017 5:47:14 PM - IPs do not match!
    10/05/2017 5:47:14 PM - Compare IPs: incoming=213.208.5.40; external=52.57.244.62
    10/05/2017 5:47:06 PM - PBX has dropped a message with 'User-Agent: friendly-scanner' from IP 51.15.147.70 because it is on blocked UAs list
    It looks to me like the 3CX does not get its external IP right.

    * Under “Settings → Public IP” I've configured to use “Static Public IP” and entered the IP.
    * The “Select network card interface” only shows the EC2's private IP not the static public IP. So this is selected (172.31.**.**).

    I tried several options on the trunk settings page but everything stays the same. I am also confused why the verbose log shows the “IPs do not match” error while the normal log shows an error regarding the “extension settings”.

    Anyone knows how to get this working?

    Thank you!

    Matthias
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,367
    Likes Received:
    228
    Who is IP 52.57.244.62? Which one of the two is your provider?

     
  3. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,255
    Likes Received:
    63
    Thats the reason why we suggest going for a supported SIP Trunk provider, these things are very rarely an issue.

    Anyhow, the issue is the following line in the capture:
    To: <sip:0@52.57.244.62:5060>

    On an incoming INVITE, the "To" fields holds the dialed number (I'm assuming that this is wrong from the Providers side). 3CX then tries to do an exact match with the number in this field against the list of numbers you have in the "DIDs" tab of the SIP Trunk settings. Exact match means that "18135910130" is not the same as "8135910130".
    If it doesn't find an exact match, it rejects the call. If it does, it tries to look up the Inbound Rule created with this DID, so make sure you also have created an Inbound Rule.

    Ask your Provider to sort out the "To" field so that that contains the dialed number.
     
  4. mburtscher

    Joined:
    Oct 6, 2017
    Messages:
    11
    Likes Received:
    1
    The 52.57.244.62 is our 3CX system. 213.208.5.40 is the provider.

    I figured out that the “To” fields holds the extension number only. So if the main number 0043/5523/21*** is called we will receive just a “0” in the “To” field. If I use a DID like 0043/5523/21***-11 it says “11” in the “To” field.

    So I thought I'd just configure the extension number as DID in 3CX but it says that a DID needs to be at least 4 characters.

    Is it possible to fix this with “Caller ID reformatting”? Couldn't get it to work :-/
     
  5. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,255
    Likes Received:
    63
    Unfortunately no, the DID must have a minimum length of 4. The Caller ID reformatting changes the "From" number, not the "To" number. The only solution I see is to ask your Provider is they can send more digits, at least 4, in the "To : User Part" on incoming calls.
     
Thread Status:
Not open for further replies.