Inbound OK, Outbound Busy.

Discussion in '3CX Phone System - General' started by SteveBall, Mar 24, 2010.

Thread Status:
Not open for further replies.
  1. SteveBall

    Joined:
    Mar 24, 2010
    Messages:
    2
    Likes Received:
    0
    I'm new to 3CX and am installing the free version for a trial.
    I have a Snom 820 hooked up.

    My setup. - All Machines = W2008 R2
    Server 192.168.1.88 (actual Machine) running Skype Gateway.
    Server 192.168.1.90 (Domain Controller)
    Server 192.168.1.92 (Hyper V) running PBX.

    For the test I have
    1) I have added a PSTN called SkypeOut - Virtual Extension 10001

    2) I have a VOIP Provider (Skype for SIP Beta..) 10000
    * Account Details : External Number 10000, Auth ID = 10000 password = 10000

    3) Set a dialing rule - Calls with 8 at the start, Route to 1) SkypeOut or 2) Skype for SIP Beta.. Both strip the leading character.

    4) On the Skype Gateway,(on .88) I have added PortID 10001 (master account) with the account with my skype in number and PortID 10000, port 6062 with a separate skype account

    Inbound is working fine. But outbound isn't.
    I have tried changing the outbound rule to have international dialing code numbers etc... but each time I keep getting back to the same thing. The phone reply's "Busy"

    Below is my log. - Any ideas? (Many thanks in advance)

    12:54:33.728 [CM503020]: Normal call termination. Reason: Busy
    12:54:33.728 [CM503016]: Call(51): Attempt to reach <sip:808000965099@192.168.1.92;user=phone> failed. Reason: Busy
    12:54:33.712 [CM503003]: Call(51): Call to sip:08000965099@192.168.1.88:6060 has failed; Cause: 600 Busy Everywhere; from IP:192.168.1.88:6060
    12:54:33.712 [CM505002]: Gateway:[SkypeOut] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CXSkypeGateway 2.0.9919.0] PBX contact: [sip:10001@192.168.1.92:5060]
    12:54:33.712 [CM503002]: Call(51): Alerting sip:10001@192.168.1.88:6060;rinstance=0866510098640606
    12:54:33.571 [CM503025]: Call(51): Calling PSTNline:08000965099@(Ln.10001@SkypeOut)@[Dev:sip:10001@192.168.1.88:6060;rinstance=0866510098640606]
    12:54:33.525 [CM503004]: Call(51): Route 2: VoIPline:08000965099@(Ln.10000@Skype for SIP Beta - Worldwide)@[Dev:sip:10000@192.168.1.88:6062;rinstance=09c2b2052871967d]
    12:54:33.525 [CM503004]: Call(51): Route 1: PSTNline:08000965099@(Ln.10001@SkypeOut)@[Dev:sip:10001@192.168.1.88:6060;rinstance=0866510098640606]
    12:54:33.525 [CM503010]: Making route(s) to <sip:808000965099@192.168.1.92;user=phone>
    12:54:33.525 [CM505001]: Ext.102: Device info: Device Identified: [Man: Snom;Mod: 8xx series;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [snom820/8.2.11] PBX contact: [sip:102@192.168.1.92:5060]
    12:54:33.509 [CM503001]: Call(51): Incoming call from Ext.102 to <sip:808000965099@192.168.1.92;user=phone>
     
  2. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,477
    Likes Received:
    67
    Hi
    "600 Busy Everywhere" is returned when you have a master configuration with at least one slave channel, and you attempt to make an outbound call through the master channel while slave(s) are available (on-hook)
    I suggest you following
    - if you really need master configuration, then try to make outbound calls through the slaves.
    - if you don't need maste configuration, make this channel a normal one.
    Master channel is designed as an inbound calls dispatcher, so an outgoing call through it would block all incoming calls so, to avoid this, it rejects outgoing calls attemtps.
    Hope it helps
    Regards
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. SteveBall

    Joined:
    Mar 24, 2010
    Messages:
    2
    Likes Received:
    0
    OK, this sounds like its probable. How do I get it to use the "Slave" as you put it?
    Do I need to add the second Skype account as a Provider or Gateway? Currently I have one Provider and one Gateway.
    I didn't think that I was dialing out via the Master.
    Many thanks
    Steve
     
  4. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,477
    Likes Received:
    67
    Hi, Steve
    The "common" configuration is following (from PBX to gateway):

    - outbound_rule_1 ---> PSTN_1 ---> skype_gw_channel_1 ---> skype_account_1
    - outbound_rule_2 ---> PSTN_2 ---> skype_gw_channel_2 ---> skype_account_2
    ..
    - outbound_rule_x ---> PSTN_x ---> skype_gw_channel_x ---> skype_account_x

    Regardless skype_gw_channel_... is master or slave, you can make outbound calls through their corresponding outbound rule (with "master" restrictions described in the previous post).
    To make the master channel a "normal" one, stop the gateway, select it, open its Configure dialog and there uncheck "master" option.

    Hope it helps
    Regards
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.