Inbound paramaters - Display company name

Discussion in '3CX Phone System - General' started by oleman, Mar 13, 2009.

Thread Status:
Not open for further replies.
  1. oleman

    Joined:
    Jan 23, 2009
    Messages:
    7
    Likes Received:
    0
    Hi,

    I am working on a 3CX project for our own use. (~50 phones, 3CX7 E1 NL)
    We have 10 different companies under one roof. Many people pick up the phone for several of these companies.
    On the phone we would like to display company name instead of incomming caller id.

    I know now that to achieve this i have to go to inbound paramaters of the line or provider. Go to content of the sip field and change the the from: user part. I would suppose to a custom value.

    Now, perhaps my very noobish question, how do i change the actual value. I see the field: 'custom value' , sounds promising, but find no way of editing it.

    Thanks for any help,

    Edo
     
  2. mbaltus

    Joined:
    Dec 12, 2008
    Messages:
    66
    Likes Received:
    0
    Assuming each of the companies using it's own number, if solved this the following way:
    - Make a ring group for each company (and insert the extensions)
    - Attach a DID to the ring group
    - Set the option to add Ring Group Names ==> settings > general > Global Options (tab), an option with "append group name to caller id" or something

    Now when dialed inwards, you see the name of the ring group in the display of your phone and personalized answering is possible.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. oleman

    Joined:
    Jan 23, 2009
    Messages:
    7
    Likes Received:
    0
    A little late, but great! It works, cheers!
    ..one small problem.. for some reason. I get the incomming caller id twice on the screen leaving little room for the ringgroup name (I only see the first 2 characters)

    I think this is because the first is the caller name(displayed as number) then the number
    e.g. From: "31624634318"<sip:31624634318@193.67.129.61>;tag=as1591adbb

    How could i surpress the name?

    I tried editing the voip provider> inbound paramaters > from: displayname.

    But that didn't work.
    Looking forward to any ideas you may have.
    cheers
     
Thread Status:
Not open for further replies.