Inbound PSTN calls dropped after specific timespan

Discussion in '3CX Phone System - General' started by snook, Apr 25, 2007.

  1. snook

    Joined:
    Apr 12, 2007
    Messages:
    4
    Likes Received:
    0
    I am using the Mediatrix 1204 4 port FXO gateway to connect to the PSTN and 3CX Phone System v3.0.1699.0.

    I got it working for both outgoing and incoming calls, however for incoming calls they are getting disconnected after precisely 30-33 seconds (with voice activity).

    This is not a Mediatrix issue because using Asterisk with the same configuration, it does not disconnect by itself.

    I have a feeling the problem may be with both 3CX and Mediatrix. Perhaps 3CX is waiting for specific queries from the Mediatrix but isn't getting them.

    Here's the last few log lines (in reverse chronological order):
    18:11:54.876 StunClient::process STUN resolved external IP=99.99.99.99[I masked the IP here on purpose]:62621 by server 194.221.62.209
    17:52:26.629 StratLink::eek:nHangUp Call(C:5): got Hang-Up from Ln:10000@Mediatrix; reason: BYE
    17:51:54.129 StunClient::process STUN resolved external IP=99.99.99.99[I masked the IP here on purpose]:63409 by server 194.221.62.209
    17:51:43.817 CallLegImpl::eek:nConnected Established media channel for Ln:10000@Mediatrix: remote=192.168.0.25:5004; local=192.168.0.10:40900

    Would you have any ideas as to what may be the issue?
     
  2. Anonymous

    Anonymous Guest

    Fair is fair, 3cx is the new component in your configuration but you log shows

    The 30-33 sectonds (most likely 35 seconds actually) has to do with the SIP registration and that is not directly related to 3cX I believe.

    It also can have to do with the FXO port impendance, this setting is unique for each country.

    Also can you check if you have something like voice mail enabled on your VSP, the message that VoiceMail is available at your VSP (not 3CX) can also cause some troubles.

    Search the forum, there are a few posts regarding the 35 or 30 seconds problem.
     
  3. snook

    Joined:
    Apr 12, 2007
    Messages:
    4
    Likes Received:
    0
    I have tried the various port impedance settings that the Mediatrix allows and none made a difference. I went through nearly every MIB setting that it offers and disabled every "timeout" variable. I also tried both increasing and decreasing any "timer" variable I could find.

    I tried different softphones, changed 3CX from forwarding to an extension to using a digital receptionist (w/ a high timeout value) and still the same issue. It keeps automatically disconnecting after about 30-35 seconds.

    Both the 3CX logs and the Mediatrix show a relatively humble disconnection message. 3CX, as shown above, says the mediatrix has hung up, while the mediatrix simply shows in its logs "Session Terminated", with no obvious log entries afterwards that indicate why.

    I turned on asterisk and tried it again - it never disconnected my inbound calls.

    This may be because the Mediatrix may be expecting some kind of response or "ping" from 3CX and is not getting it. I'm not sure. I think I've exhausted most of my ideas at this point. =(
     

Share This Page