Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Inbound PSTN calls not routing.

Discussion in '3CX Phone System - General' started by eddix99, Jan 22, 2010.

Thread Status:
Not open for further replies.
  1. eddix99

    Joined:
    Jan 22, 2010
    Messages:
    5
    Likes Received:
    0
    Hello,

    I am new to the 3cx platform but I have a few years experience as an administrator, so I know the IP side of things.

    I am putting together a small platform to learn the system. I have got quite far with it but am stuck with one issue. My inbound PSTN calls are not ringing on my extensions.
    I have the following setup:
    • 3cx Server (latest vesion, Server 2003)
    • Linksys spa3102 gateway
    • Linksys spa 941 & 3cx softphone

    Below are some points which I feel are important to giving you an overview of my setup:
    • I have setup the gateway exactly as it states in the configuration guide for the spa3102.
    • I have connected the phones and the gateway to the pbx and get green status lights.
    • I can make internal calls between my phones.
    • I can make external calls from my phone(s)
    • I have connected an analogue phone to the line socket of the voip gateway and am receiving calls on that
    • On my 3cxphone 4 I have made sure that the program appears in the firewall exceptions of my local pc.
    • In the ports/trunks status menu of the system config I have specified an extension to forward calls to (the 3cx softphone)
    • I have not set any DID inbound rules.

    I feel that it could be that the gateway device is not picking up calls and/or notifying the pbx. I cant find any activity from the pbx side of things in the log to paste here. I have tried to upload a pdf of the voip config utility but am not allowed to upload pdfs to this forum.

    Does anybody have some pointers for me?

    Thanks

    Edward
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,127
    Likes Received:
    330
    First off, you have to determine if the incoming call is even reaching the PBX. Try an incoming call then open up the 3CX server log and see if the 3102 passed the call info to 3CX. If you don't see anything showing an incoming call then the 3102 has a datafill error, somewhere. (quite common). Go back over all of the settings again and make sure you haven't missed something.

    Sorry, i missed the part about the calls ringing in on a set plugged into the phone jack on the 3102...

    In the 3102, go to the PSTN tab/PSTN-to-VoIP Gateway Setup/PSTN Ring Thru Line 1 and set that to NO (the default is yes) that will prevent calls from going to the set plugged into the "Phone jack" and hopefully send them to 3CX. There may be some other settings that need tweaking to , but start with that.
     
  3. eddix99

    Joined:
    Jan 22, 2010
    Messages:
    5
    Likes Received:
    0
    Thanks for your input leejor.

    I have tried to disable the ring through option but it has no effect.

    What I was going to suggest was forwarding over to you some screenshots of my configuration. That way you might find something glaringly obvious.

    I have tried to upload a pdf onto the site but was prevented from doing so. Is there any other format that I can use to get this info over to you?

    Regards


    Edward
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,127
    Likes Received:
    330
    I haven't posted a screen shot myself but usually save the pages for reference using the FILE, then , function. Before you start doing that... I would assume you used the 3CX gateway config guide? One problem that people had found with that, and it hasn't yet been corrected, is that in the PSTN Line tab/PSTN-toVoip Gateway Setup, it says to set the "PSTN Caller ID Pattern" field to "*", leave that field blank. See if that makes a difference. Go back over all of the settings in the PSTN Line and PSTN User tabs.

    The 3102 "speed dials" the trunks number, the 1000X number you put into dial plan 8 when you receive an incoming call. For that to work correctly you have yo make sure that everything is in EXACTLY right or the 3102 won't know where to send the calls. Make sure that the port number of the PSTN on the 3102 matches the port number in the 3CX trunk datafill. 3CX default is 5062, the 3102 default is 5061, so none must be changed to match the other.
    Was the 3102 used with a provider before? if so then some of the other defaults may have been changed and you may want to do a factory reset on the device and start from scratch. Do a search through the forum too. There have been a number of people that have encountered the same problem.
     
  5. eddix99

    Joined:
    Jan 22, 2010
    Messages:
    5
    Likes Received:
    0
    Hi Leejor,

    Your solution worked!

    Taking the * out of the caller ID pattern solved my issue. Now my inbound calls are being picked up by the 3102.

    Thanks for all your help.

    Kind Regards

    Edward
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,127
    Likes Received:
    330
    Yeah, that was "discovered" by someone, after more that one person had problems, several months back.
     
Thread Status:
Not open for further replies.