Inbound Rule not functioning for "Out of Office"

Discussion in '3CX Phone System - General' started by Sal, Jun 9, 2017.

Thread Status:
Not open for further replies.
  1. Sal

    Sal

    Joined:
    May 12, 2017
    Messages:
    5
    Likes Received:
    1
    Hello, I'm trying to configure one of my DID's to route to an alternate extension during after hours. The purpose is to have an after hours extension for support.

    I have my DID Inbound rule setup as such, "In office Routing" set to extension 2000, "Out of Office" set to ring at ext 1000, pretty straight forward. I don't have "Set up Specific Office Hours for this trunk" configured as I am relying on the "Timezone, Office Hours & Holidays" under settings configured. Although I did try it before posting here to see if that would work.

    The issue I'm having is the "Out of Office" extension 1000 is overriding my "In office Routing" to extension 2000. Meaning if I call that DID the calls automatically go to extension 1000 regardless of what time it is. If I replace the "Out of Office" with extension 2000, then ext 2000 will pickup. It's almost as if the Inbound DID rule is disregarding the Hours of operation and just routing the calls to whatever value you have set in the "Out of Office" field.

    I'm running PBX Express in the cloud version 15.5. Any ideas what I'm missing or is this a bug in the current version? Extension 2000 is a 3CX Android App. Extension 1000 does not yet have any phone configured to it.

    I hope I was able to explain this well, any thoughts here or suggestions?

    thanks in advance
    Sal
     
  2. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,216
    Likes Received:
    87
    one very common this is that the HOST time is not the time as you assume in the PBX.
    Entering 2pm in 3CX means 2pm of the host os time and not the timezone you configured in the at setup...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Sal

    Sal

    Joined:
    May 12, 2017
    Messages:
    5
    Likes Received:
    1
    Hello, thanks for the quick reply. I'm not sure where the Host time setting is at. I'm assuming you are referring to the OS time. Since this is a PBX Express installation on the 3CX cloud servers where would one make the change on the Host side for the correct time and time zone? I currently only have access to the GUI side of it. Below is the only time zone setup I see for the PBX side.

    upload_2017-6-9_10-0-15.png
     
  4. Sal

    Sal

    Joined:
    May 12, 2017
    Messages:
    5
    Likes Received:
    1
    Upon further inspection, my system does appears to be in a different time zone. In playing with the Office Hours schedule listed above I was able conclude that my system is operating 7 hours ahead of Local Pacific Time. For example my local time is 11:10am but the system is acting as if it's 18:10.

    It does appear that the Host time is throwing off the above office hours schedule. This could be related to the Host time (Operating System) not setup properly. As mentioned this is a 3CX PBX Express installation setup in the Cloud. I believe the cloud provider I selected here in the US is OVH. Any ideas how to correct? Or is there some Parameter I should be looking at under the Parameters section?

    thanks in advance
    sal
     
  5. jbryant84

    jbryant84 New Member

    Joined:
    Apr 6, 2016
    Messages:
    109
    Likes Received:
    40
    I'd figure how many hours off the host is, and just factor that into whatever you set in global office hours. Just apply an offset.
     
Thread Status:
Not open for further replies.