Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Inbound Rule not routing correctly. PLease HELP

Discussion in '3CX Phone System - General' started by djboxny, Aug 8, 2010.

Thread Status:
Not open for further replies.
  1. djboxny

    Joined:
    Aug 8, 2010
    Messages:
    42
    Likes Received:
    0
    The skype In number that i have set up is listed as a DID in the Inbound Rules, Also i put it to foward the calls to 800 (receptionist) But it is rounting the call to ext 100. Everytime someone calls it says that the rule is Unamed Even do i created multiple rules for this skype gateway to see if it work. How do u configure the Inbound routing for the skype gateway. Thankss


    14:17:13.268 [CM503008]: Call(7): Call is terminated
    14:17:11.692 Currently active calls - 1: [7]
    14:17:04.113 [CM503007]: Call(7): Device joined: sip:999@127.0.0.1:40600;rinstance=abe76901cd2caa2e
    14:17:04.109 [CM503007]: Call(7): Device joined: sip:10002@127.0.0.1:6060;rinstance=b3e55c038ba7a48e
    14:17:04.100 [CM505001]: Ext.999: Device info: Device Identified: [Man: 3CX Ltd.;Mod: Voice Mail Menu;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CX Voice Mail Menu] PBX contact: [sip:999@127.0.0.1:5060]
    14:17:04.099 [CM503002]: Call(7): Alerting sip:999@127.0.0.1:40600;rinstance=abe76901cd2caa2e
    14:17:03.901 [CM503025]: Call(7): Calling Ext:Ext.999@[Dev:sip:999@127.0.0.1:40600;rinstance=abe76901cd2caa2e]
    14:17:03.846 [CM503005]: Call(7): Forwarding: Ext:Ext.999@[Dev:sip:999@127.0.0.1:40600;rinstance=abe76901cd2caa2e]
    14:17:03.842 [CM503016]: Call(7): Attempt to reach <sip:100@173.220.110.116:5060> failed. Reason: Not Registered
    14:17:03.841 [CM503017]: Call(7): Target is not registered: Ext:Ext.100
    14:17:03.836 [CM503010]: Making route(s) to <sip:100@173.220.110.116:5060>
    14:17:03.830 [CM505002]: Gateway:[Skype - user (djboxny) US-CAN-PR free] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CXSkypeGateway 2.0.9919.0] PBX contact: [sip:10002@127.0.0.1:5060]
    14:17:03.823 [CM503001]: Call(7): Incoming call from +17184080771@(Ln.10002@Skype - user (djboxny) US-CAN-PR free) to <sip:100@173.220.110.116:5060>
    14:17:03.802 [CM503012]: Inbound out-of-office hours rule (unnamed) for 10002 forwards to DN:100
     
  2. TotallyVoIP

    Joined:
    Jul 2, 2010
    Messages:
    77
    Likes Received:
    0
    I'm having a serious issue with inbound routing via the skype gateway, but mine is relating to multiple skype accounts. I am waiting for a response from 3CX (they have my wireshark and logs etc) I will let you know the outcome.

    In the meantime I will try and test with fewer gateway accounts (currently 7), and maybe try just one to see if the problem is even worse than I thought?!!

    Exactly what have you configured?
    How many skype accounts? If it's multiple then you may be having the same issue as me? Is anyone out there getting multiple skype accounts to route to different interal extensions?

    Best to check the ports (6060?) on both the PSTN section of the PBX and the skype config match, along with the other ID's.

    Try removing the DID rule and just routing via the Trunk settings to see if that goes where you want it,
    if that works then try adding a DID rule, using * as the mask and seeinf how that goes.

    If you can give some more info?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.