inbound rule to external number

Discussion in '3CX Phone System - General' started by Zennix, Dec 17, 2014.

Thread Status:
Not open for further replies.
  1. Zennix

    Joined:
    May 21, 2014
    Messages:
    10
    Likes Received:
    0
    Hi all,

    we want to place an inbound rule to redirect one of our extensions of the trunk to an external number. So good so far.
    The problem is, that if somebody externally calls the number, the 3XC redirects the call to the other external number and this phone is ringing. The caller gets no acustic signal, the phone shows dialing in screen. The receiver of the call takes the call and everything seems to be OK. But no voice connection is established. Caller and Receiver listen to a dead line.

    I talked with our SIP Trunk provider and his log show, that the connection was successfully.

    There is only minimum changeable values for that rule. Didn´t know what could be wrong on my side.
    Anyone with an idea?

    Greetings / Thomas
     
  2. Pauliebrisbane

    Joined:
    Nov 14, 2014
    Messages:
    17
    Likes Received:
    0
    Do you have a copy of the trace?

    Are you seeing a SIP 180 Ringing message in the call?
     
  3. Zennix

    Joined:
    May 21, 2014
    Messages:
    10
    Likes Received:
    0
    Hi,
    yes 180 ring message is in the log.
    I attached the log.
    In the log I replaced the numbers to caller an receiver.

    Thanks / Thomas
     
  4. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,083
    Likes Received:
    61
    The ring (180) is a part of the SIP response, the concern is:
    No RTP packets were received:remoteAddr=XXX.X9.2XX.XX8:22328,extAddr=0.0.0.0:0,localAddr=XX2.1XX.XXX.XX1:9044

    (Please note that you hid non-essential extension references and left the IP info. You should edit the post to remove the external IP info so that those who have a penchant to try and hack your system, will be likely to be able to)

    As you can see, the system is telling you that no RTP (voice stream) packets were received. This is where a Wireshark capture may be handy so one can see what was contained in the SDP where the ports to use were negotiated between devices.

    The SIP provider will likely show it as completed, because from the SIP standpoint it was. However the audio is handled by a media server which is expecting to see the RTP stream on a certain port just as 3CX is also expecting to see the return audio on a given port. For some reason, usually a firewall, the streams are not getting to the desired ports; hence why no voice.

    Have you port forwarded the needed ports and run the firewall checker with passing results? What router make/model is in use?

    Some terminology confusion exists on my part with regard to:
    "place an inbound rule to redirect one of our extensions of the trunk to an external number".

    I take the above to mean that you have various DIDs associated to your SIP account and that you wish to have an inbound rule that looks for a particular DID and when found, will direct it to an external number.

    It is a little hard to follow the log, but you may want to check the provider settings with regard to how they are set-up under the advanced settings. Specifically look (and toggle for testing) Replaces and Reinvites. I see that your SIP provider is listed by 3CX (at least in V12.5 RC1) and that the setting only has PBX provides audio and the others are unchecked.
     
  5. Zennix

    Joined:
    May 21, 2014
    Messages:
    10
    Likes Received:
    0
    Fixed

    Thanks for the tip.
    The firewall was the solution. It dropped UDP pakets.
    I defined a rule in the firewall to pass UPD pakets from the 3CX IP for source port 9000-9050. That´s it.

    Thanks / Thomas
     
  6. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,333
    Likes Received:
    256
    I'm surprised the sip trunk had audio in the first place...
    Wouldn't the firewall checker fail in this case?
    Page 11 of the manual talks about the required ports in the firewall...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Zennix

    Joined:
    May 21, 2014
    Messages:
    10
    Likes Received:
    0
    Hi,
    unfortunately, in our firewall, we have to distinguish between outgoing and incomming traffic. I didn´t realize that this kind of traffic needs source port permissions too.
    Manual:" Port 9000-9049 (or higher) (UDP) (send & receive) for RTP communications"
    Without external rule everithing is working fine.

    Thannks / Thomas
     
Thread Status:
Not open for further replies.