Inbound Vitelity voip provider not working on V5

Discussion in '3CX Phone System - General' started by webguyz, Dec 10, 2007.

Thread Status:
Not open for further replies.
  1. webguyz

    webguyz New Member

    Joined:
    Jul 19, 2007
    Messages:
    126
    Likes Received:
    0
    Hi,

    Have latest V5 installed and added my BroadVoice and Vitelity voip providers. The Broadvoice works inbound and outbound just fine, but the Vitelity inbound errors out with:

    [CM102001]: Authentication failed for SipReq: INVITE 888xxxxxxx@206.xxx.xxx.xxx tid=74536006 cseq=INVITE contact=214xxxxxxxx@64.2.142.30 / 103 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings

    I dimly remember having to validate the incoming call by checking the IP or something but not sure where it is. Can any one offer any suggestions?

    Thanks!
     
  2. webguyz

    webguyz New Member

    Joined:
    Jul 19, 2007
    Messages:
    126
    Likes Received:
    0
    Ok,

    Printed out the settings for my V3 and compared them to my V5 and think I know where the issue is:

    In V3 under Other Options >>> I have
    Use IP in 'Contact' to recognize source - checked
    IP Range - IP address of vitelity:64.2.142.30

    These are no longer in V5 or they are called something else. Can anyone tell me what the V5 equivelant of the above 2 options? All my other options are the same expcept for these 2.

    Thanks!
     
  3. RichardU

    Joined:
    Dec 12, 2007
    Messages:
    7
    Likes Received:
    0
    Did you ever figure out this problem?
     
  4. webguyz

    webguyz New Member

    Joined:
    Jul 19, 2007
    Messages:
    126
    Likes Received:
    0
    Yes,

    In Source Identification > Match Any Field >

    Contact: Host Part | Custom Field | 64.2.142.30:5060

    Now everything works including the additional DID's we have with Vitelity.
     
Thread Status:
Not open for further replies.